Mouse speed setting does not work in MacOS Mojave

I just updated my macbook to MacOS Mojave few days ago. I have found that the mouse speed setting in BTT does not work at all. Any help please.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook pro 2018 with touchbar.

Device information:

  • Type of Mac: Macbook pro 2018 with touchbar
  • macOS version: 10.14.3
  • BetterTouchTool version: 2.697

Update
I tried to reset the Accessibility permission database. Still does not help.

Sorry Apple has removed the ability to change the mouse speed higher than the default values in 10.13 or 10.14.
(There may still be some way, but I haven't been able to get that to work yet)

Damn, my computer feels broken at the max mouse speed that apple allows.

Agreed, the max speed in Mojave is way too slow for me too. I really hope you find some way to get it working again.

Strangely, "Change mouse speed while holding" still works if I set it to, for example, shift key.

There is a tool that can change the speed: CursorSense
However I currently believe it can only do that because it's a preferences pane. I tried various ways to integrate that into BTT, but they are all blocked by the system.

Why does it work in BTT with the "while holding" setting? Pardon my coding ignorance, but isn't there some way to set it to that state without the additional key press?

That doesn't go higher as the system default either, or does it? Maybe something has changed with the recent macOS update?

It does indeed work for me with the "while holding" in MacOS 10.14.3

That's interesting! Then I'll enable the same method for the normal mouse speed setting with the next update.

2 Likes

Thank you! I'm looking forward to it.

Came here to say this... I was also able to setup a keyboard shortcut to change the mouse speed in which case it does indeed change the speed permanently or at least until the shortcut deactivates?

It would also be nice to have some UI change or something that displays what shortcuts have been activated, or a toast notification that tells that it has been activated in the first place?

One other thing, I moved the slider in the UI and the speed of the mouse did not change, went through all the troubleshooting I found about mojave to no avail... Then I uninstalled BTT, deleted the application support folder and then reinstalled and found that the value I entered (18 which is what I use on my other that's still on 10.14.2) was already set upon installation somehow... I'm not sure where this information is stored, but somehow reinstalling did in fact change the value and I have noticed that the mouse speed is quicker... it seems really weird to me but as a fellow dev thought this might help demystify things.

This should work again in v2.703 alpha!

1 Like

Hi,

I have recently downloaded the trial version of BTT, because the Magic Mouse tracking is too slow for my taste. But as this original post stated a year ago, the mouse speed setting does not go above the maximum system setting.

I still use Mojave, that is why I hope to get any useful information about the issue.
I have tried to install the older version you mentioned, but it says that there is no Magic Mouse connected or something wrong with the drivers.
I don't know where to find the drivers it needs, maybe that would work...

Any type of help would be really appreciated, it makes me so frustrated every single day.

System information:
Mac Pro 5,1
MacOS 10.14.6
BTT version: 3.373 and the 2.703 alpha

sorry since Mojave the speed can not be higher than the system maximum. There is another app that can still do it by integrating into system preferences (some japanese app I think) but I forgot the name. It was something like MouseControl, maybe you can find it here in the forum - it was mentioned somewhere

I think it is the app called SmoothCursor. It does work but it also makes the cursor very inaccurate. It looks like I have to get used to this.
Other than this small thing the app is really awesome, I have already purchased it. Keep up the good work!
(By the way thank you for the quick reply)

ahhh yes that was it.

Unfortunately the issue you described is a side effect of how the app works;-(

It’s a shame apple prevents the higher speeds that were possible on older macOS versions...

Imprint | Privacy Policy