Mouse button as keyboard shortcut - issues with holding modifiers

Hey there, I'm having some issues with my Logitech MX3 and wondering if there are any solutions. I've set the mouse buttons as keyboard shortcuts, so for ex one of the buttons inputs F5. I have a shortcut on BTT to increase volume that is CMD+F5 (or CMD + mouse button in real life). The think is it doesn't work if I press CMD and click the mouse button (emulating F5) more than once. I'd have to let CMD go and press it again. It does work if I do it directly on the keyboard tho. I also tried other keys besides F5 buy had the same issue. Anyway, any help would be appreciated! Thanksss!

Did you assign the keys to the mouse buttons inside the logitech app? Or only inside BTT?
I tried predefining my mouse buttons via logitech once and it led to a lot of issues for me inside BTT.

Maybe you could post a screenshot of your Trigger Setup?

Seems to me you need to enable key repeat ... maybe.

In the Logitech Options+ app yeah, since BTT doesn't detect the mouse buttons :frowning:

Here's a screenshot.

Yeah I tried that, which worked for when using only the keyboard and holding both keys, but it doesn't work for the mouse. What I want to do is to hold Opt and then press F5 several times if that makes sense.

I just tried, to reproduce your setup on my mac and see, if I run into the same issue as you. Funnily enough, it didn't work at all for me. When I assign a regular Key(e.g "F5") to a Mouse Button via Logitech app, BTT will only recognise it correctly, when recording the shortcut for the trigger. For activating the trigger it does not work at all. :thinking:

However, when I select just the default mouse buttons in Logitech G HUB, I can use all buttons without problem in BTT. So maybe there could still be a chance, that it's possible to assign regular mouse buttons via Logitech Options+ app? I know the BTT documentary says, that it won't work with the newer mice. But It says the same thing about the Logitech Gaming Software, which doesn't seem to be true anymore.

You could also try out Steermouse, if you haven't already. I'm sure it's worth a try.

Found here:

Ha, funny. I think I had the same issue when I was using my G604. Unfortunately I don't think I can set a 'Mouse Button' on Logi Options, at least I couldn't find that :frowning:

A combo of BTT + SteerMouse made the trick!! I was able to add actual Mouse Buttons to my MX3s and BTT identifies that <3

The only issue so far is that if a add a keyboard key on SteerMouse it doesn't work on BTT - which I tried with the horizontal scroll since I couldn't add a mouse button there. Will explore a bit more, maybe there's a trick.

That's great news!. I'm glad it worked. :slight_smile:

I had the same issue, with the horizontal scroll and found a workable solution for me in just assigning a "Shift Key Modifier" to one of my mouse buttons. So whenever I press Mouse 3, I scroll horizontally.

You just have to keep in mind, that you will need two triggers, in order for it to work.
CleanShot 2022-12-06 at 21.34.17

Alternatively uninstalling the Logitech options app completely also usually makes the mouse work with BTT.

I need to check what the logitech software is doing - probably it's catching the mouse events at a lower level before BTT sees them.

Ohh I haven't tried that but the BTT + Mousesteer combo is working great. I couldn't make mouse button 5 and 6 work on BTT, had to set keyboard keys to those but other than that all good. Mousesteer was very nice for using the horizontal scroll for changing media volume which I wasn't able to make it work well on BTT. But anyway, problem solved I guess, thanks everyone!