Mouse actions with exclusive triggers don't work

Screenshot 2024-03-07 at 16.45.49

I defined the above shown triggers which - in my opinion are exclusive to each other. All are triggered by the middle mouse button but one action only works on the menubar and the other two either in full screen active or inactive. However, this does not seem to work - only one of them does, probably the one with the latest changes. This one works under the right trigger conditions.

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

MacOS 14.3.1 (23D60)
BTT 4.430

that seems to work fine here. Possibly the fullscreen_active variable doesn't work in all apps, are you trying this in a specific app?

Even if the variable doesn't work the behaviour is inconsistent. My guess is simply that if the trigger conditions are evaluated to false it does not check the next item with the same mouse button. Or are all item evaluated in parallel when - in this case - they are based on the same mouse action?

What I see: If I have two items both with action middle mouse button only one of them works, even when the trigger conditions are ecxlusive to each other. I restarted BTT and rebuilt all actions.

I tried again on two machines with the setup you posted, but it's all working fine here.
Could you try to reproduce the issue, then go to Help => Export Diagnostic Debug Information and send the result to Maybe I can see in the logs what is going on.

The good thing is, with your debug data I can reproduce the issue. That bad thing is, it seems to be something pretty deep down the stack and I haven't figured out the exact cause yet.

For now you can workaround the issue by setting it to trigger on mouse-up instead of mouse-down

For me it also works if I delete the triggers and create them again.

I think I might have found the root cause, it should be fixed in 4.433 alpha

1 Like

Verified with 4.433 Alpha - works now as expected - great! Thanks!

1 Like