Modifying date/time widget in AquaTouch provokes crashing (solved)

Whenever I try to change the date format in any way, BTT crashes, restarts and restores the date format to preset's default.

Where are you changing the format? Is this in System Preferences, BetterTouchTool Editor or AquaTouch itself?

Open QuickControls → QuickSchedules → Date and time widget

What format are you trying to set?

This might be more of a BTT issue as opposed to an AQT issue

I'm trying simply to set HH:mm, but actually any change to the format provokes this effect. Should I change the tags and title of my thread so this is treated as a general issue?

Seems to be a BTT bug... Maybe try reinstall AQT? (AQT preferences will be kept)
Just tried and I was able to set it

if that doesn't work yeah, probably need to ask @Andreas_Hegenberg

I gave a AquaTouch a second shot and installed it again. Same problem. I cannot change anything in your time widget (under QuickSchedule). I can modify other widgets as normal. As for this one, I cannot even turn it off.

Then, while writing these lines, I had a desperate idea. I changed the timezone of the widget to system. Oddly, it worked and I can modify everything.

strange, it should already be set to system..

It was set to Manually set or something similarly sounding.

Imprint | Privacy Policy