Modifiers keys: fn Key Down or fn Key Up don't work (SOLVED)

I expected "fn Key Down" action will keep fn Key pressed down similar to CMD Key Down / Ctrl Key Down. However, it doesn't keep pressed down at all.
For example, I configured the sequence as Double fn Key to activate "fn Key Down" action. Then I have very custom shortcuts by using "fn + ..." (such as "fn + J" to simulate key "arrow left").

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook pro 13 2018
  • macOS version: 10.15
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.389

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I am seeing a similar problem. I am trying to use the Keyboard Modifier Actions of Option Down and Option Up, as well as Control Down and Control Up. However, assigning these actions to Keyboard Shortcuts have no effect.
Mac Pro, late 2019
macOS 10.15.5 with the Supplemental Update.
Better Touch Tool 3.389

Hi David,

I just double checked Option Down / Option Up and Control Down / Control Up, and it works for me.
I did the following test:

  1. Recorded the key sequence: FN FN.
  2. Assigned action as: Opt Key Down
  3. Recorded the key sequence: SHIFT SHIFT
  4. Assigned action as: Opt Key Up

And then, I opened Sublime text:

  1. Double press FN key
  2. My arrows now allow me to jump per word rather than a character. So, it works.
  3. Double press SHIFT key
  4. My arrows returned to normal as moving only a character.
    The similar test for Ctrl Key Down and Ctrl Key Up works fine.

My only problem is the same configuration doesn't work for FN key. So, it is not pressed down even I execute action "fn Key Down" or "fn Key Up"

Screen shot:

Hey supersimo,

Thank you very much for testing. Given that the Actions work for you, I continued to investigate, and found the cause. I was using the Option key in my Key Sequence (which is the Key being acted upon by the Action.). When I removed it from the Key Sequence, the problem did not occur.
I also tried your issue, assigning FN FN to the Action fn Key Down. As with you, it did not work.
Regards and good luck.

Hi @Andreas_Hegenberg, can you look into this defect, plz.

I found the workaround. I enabled sticky keys (Accessibility -> Keyboard -> Enable Sticky keys).

It helps to double click on FN key to lock it down and up.

Now, I can remap my entire keyboard with the custom shortcuts/layout.

For example:

  • key j = "arrow left" (+ all combinations with command, options, shift)
  • key i = "arrow up" (+ all combinations with command, options, shift)
  • key l = "arrow right" (+ all combinations with command, options, shift)
  • key k = "arrow down" (+ all combinations with command, options, shift)
  • key u = "enter"
  • key o = "delete"
  • key p = "esc"
  • key m = "[" (+ shift = "{")
  • key . = "]" (+ shift = "}")

Also, key 1, 2, 3 as Finder opens specific folder

I hope it helps someone else, who prefers to keep fingers on "JKL:" for fast typing/coding rather than jumping on the farthest keys.