Modifier keys are not recognised

Hello there!

Well, I installed the latest trial version 2.667 on 10.14.2 and tried to re-assign the modifier keys to my liking.
I can change them normally using Mojave's default Settings->Keyboard->Modifier Keys but the options where limiting.
In BTT all the changes for other normal keys worked immediately without any special treatment, but NONE of the command keys are detected, no matter what compatibility settings I choose from, either on the specific app I want or globally.
I have a mechanical USB keyboard (ASUS Claymore) plugged in.

Only the keyboard I've tried, no other input method is available (desktop Mac)

No screenshots needed, since the problem is self explanatory. All the pressed buttons appear on the first input tab immediately, apart from all modifier keys (Ctrl, Win key, Alt & Menu) on either sides of the keyboard. Double checked and defaulted all settings of keyboard, in case they were conflicting but still the same behavior from BTT. I did also reboo, but had no effect.

Any ideas why this may be happening?

(I use the keyboard months now with my Mac but had no problems whatsoever, just wanted to get the proper shortcuts to be the same as it happens with default Apple keyboard in Adobe CC 2019 suite)

Device information:
iMac (27-inch, Late 2013)

  • BetterTouchTool version: 2.667 trial

Thank you in advance

I'm not exactly sure what you are trying, but BTT can not record or remap single modifier keys. BTT is not a key remapping tool, it's more for shortcuts.

If you want real key remapping have a look at Karabiner Elements, it works at a lower level than BTT and can remap modifier keys and the like.

Thank you Andreas for your quick reply!

I didn't know it that you cannot remap keys, it's how it was recommend from a user on reddit, thus I gave it a try.

I will give Karabiner Elements a try as well, it seems that it is what I was looking for at first place.

Thank you once again Andreas and God bless you :slight_smile: