Mission Control with desktop previews broken on Mojave?


I have a 15” MacBook Pro with TouchBar running Mojave, and I’m trying to set up a new external keyboard and mouse to replace the trackpad. One gesture I use regularly on the trackpad is four-finger swipe up for mission control with desktop previews. I use this to change desktop, as well as to reorder windows. I tried setting a button on my mouse to the ‘mission control with desktop previews’ action, but I don’t get the desktop previews. In fact I get exactly the same results if I use the ‘mission control’ action without the desktop previews. Is this know to be a bug? I saw some users discussing the same behaviour over on the old support forums but I couldn’t tell how far you’d got towards a fix? I can open a bug report, but I thought I’d check if it was already a known bug first?


Just tried and it works for me on 10.14.2

That's bizzare. I'm only on 10.14.1 atm, but it seems unlikely that's the problem. It seems to be a problem with the mouse I'm using, as I've just assigned it to a two finger tap on my touchpad and it works fine. Incidentally, mousing over the desktop names at the top of mission control (when the previews aren't open) isn't opening them either (using the mouse, works with the touchpad), and I was having problems dragging individual windows around while in mission control using the mouse, but again not with the touchpad. Is there a reason that things should be working differently for the external mouse?

it's possible that the mouse driver is interfering with this.
The action is unfortunately not very robust against external influences, because all it does is move the mouse cursor to the top and back (invisibly) after opening mission control.

So it seems that my problem is that my mouse doesn't have a proper hover state. In any of the places where I would expect hovering to do something (links in safari for instance), I don't get the expected behaviour. This would explain why the desktop preview doesn't open as well, as your method involves moving the mouse up to hover over, but even manually hovering over the desktops doesn't cause them to open. I don't suppose there's any mouse settings in BTT that are likely to help me are there?

That sounds weird. Do you have other mouse related tools installed that could conflict with BTT or with the mouse driver maybe?

Not that I'm aware of. It's an old gaming mouse (MadCatz RAT5) that I remember I used (on a previous macbook) to have a manufacturer supplied piece of software to manage, but that doesn't seem to exist anymore and so I've just been ignoring it. I wonder if the default OSX mouse driver doesn't handle this mouse properly for some reason?

Ok sorry, after the most recent restart of my machine the mouse drivers have started working and now BTT is working as expected. This thread can be deleted.