Middle click drag on Trackpad

Thanks, this works, but I can't get it to release unless I hit the escape key. Is there a way to get it to release by tapping or just raising your finger?

It should automatically release after removing all fingers from the trackpad.
Could you check whether the named trigger is correctly imported?

Which version of BTT are you using?

I'm using BTT 2.536 and macOS 10.13.6, and also have it correctly imported.

Mh it that case it should work fine (it does here).
In what kind of app are you testing it?

Maybe try enabling "show hud" for the middle_mouse_up trigger to see whether it gets triggered correctly.

I'm using it with Blender 2.79b. In Edit Mode, pressing C then left click and drag (single finger double tap and drag) selects items, while middle click and drag deselects items. I'm trying to get the three finger double tap and drag to emulate this.

Also, every time I use it, a few other things become non responsive, for example, I use a hidden dock and run the pointer along the bottom edge of the screen to get it to appear. However, it won't appear after I use the three finger double tap, even after using the escape button to get out of it. I have to restart BTT in order to get the dock to show.

I tried enabling "show hud" button nothing came up.

Weird, if the hud doesn't show up that means the "Middle Mouse Up" action is not triggered - which explains your issues.

Could you check whether the time is also imported correctly? And maybe check in live view if really nothing is showing up anymore (I have had defective Trackpads which always detected some phantom touches before).

Yes, the time is imported. I'm not sure what you mean about 'check in live view', how do I do that? The behavior occurs on both my Magic Trackpad and on the trackpad on my MacBook Pro.

Live view can be triggered here:

Ah wait, actually it won't work correctly with three finger double taps because they only trigger after all fingers have left the trackpad ;-(

Maybe try if you can get used to the three finger click trigger, that should work fine in all situations.

I still get the same behavior when I switch it to 3 finger click.

Also, how would this differ from what the 'Use special middle click mode' check box is supposed to do? BTW, I can't get that to work either, nothing happens when it's checked.

I managed to get it to work by configuring BTT directly and not importing the file mentioned above. I set 3 finger tap to Custom Click: Middle (down) with middle_mouse_up as a Named Trigger, then going to the Other tab and configuring the named trigger to be a Custom Click: Middle (up). It now works as desired using a 3 finger tap instead of 3 finger click or 3 finger double tap. Thanks.

@tiptongrange I'm happy you made this work. I'm looking for the same functionality.

Could you please elaborate, maybe with a few screenshots? I'm a bit new to BTT, and your paragraph is simply over my head and I am not able to set it up.

Thanks in advance!

Open the Preferences and select Add New Gesture. You can refer to my screenshots for the following steps. (Screen Shot 1)

  1. Select the Predefined Action Menu
  2. Select Mouse Click Actions within that menu
  3. Select More Mouse Buttons & Modifiers

A new window will pop up (Screen Shot 2)
4. Select the Trigger Mouse Down
5. Select Middle Mouse Button

Now that the mouse click is down, you need a way to release it. Here are two ways. The first way is to configure the gesture to release the click. (Screen Shot 3)

  1. Select the gear under Touchpad Gesture which will bring up another window (Screen Shot 4)
  2. Enter a name for the trigger
  3. Enter the length of time for the delay after you lift your finger before the trigger is executed. You can experiment with this number. A longer delay will allow you to lift your finger to reposition it on the trackpad without releasing the click. A shorter delay will release the click earlier and allow you to work more quickly.

That middle_mouse_up command came out of nowhere, so the last thing we need to do is assign that command to release the click. (Screen Shot 5)
9. Select the Other tab
10. Select Configure New Trigger

(Screen Shot 6)
11. Select Please Select a Gesture
12. Select General from the pop up
13. Select Named Trigger

A new window will appear (Screen Shot 7)
14. Enter the name of the trigger "middle_mouse_up" without the quotes
15. Then click Save

After you save the above (Screen Shot 8)
16. Select the Predefined Action button
17. Select Mouse Click Actions from the menu
18. Select More Mouse Buttons & Modifiers

A new window will come up (Screen Shot 9)
19. Select Trigger Mouse Up
20. Select Middle Mouse Button
21. Click the Save Button

The above steps should allow a three finger tap to work as a middle mouse click by itself. However, I had problems getting the click to release, so I created a second gesture to release the mouse. I used a three finger double tap to release the click - just go through steps 1-5 but select Trigger Mouse Up on step 4.
(Screen Shot 10)


You are an absolute hero @tiptongrange. I am flabbergasted. What an amazing guide you put together. THANK YOU!

(Man, BTT is seriously powerful, but the UI/UX for this is pretty insane. Thanks again.)

You must be a technical documentation writer by trade or I don't know.

Thanks for the compliment, however I'm an architect, not a technical writer.

Just curious, did you get it to work for you, and did you use one gesture and go through all the steps above to release the click by itself, or did you use a second gesture to release the click?

I have installed BTT for macOS but I can not use BTT special middleclick mode in TeamViewer session. I am using TeamViewer installed in macOS to work with CAD Tool for Windows. There is a zoom mode working correctly only if I hold down the middle button of the mouse. It requires holding the middle button pressed but I can not reproduce it when I applied [x] Use special middleclick mode ( for CAD users ) on Predefined Action Settings in [Advanced] settings. So my question is about how I can use the middleclick mode with TeamViewer. My CAD tool for windows is Creo Parametric.

Note I am using macOS Majave 10.14.3

Hmm... It started working after system reboot. But there is a critical problem I found. If I setup the middle button click on "3 Finger Click" at [Trackpads] then it works only when I choose [x] ^ctrl. Otherwise it works from time to time only. If I setup the middle button click on "3 Finger Click" for my Magic Mouse it works from time to time always independently from [x] ^ctrl. Finger taps don't work for Trackpads at all...

Yes! It's not working for trackpad. This is only that need for me. I seen more applications for customization trackpad gestures, but I not find really working apps. Why?