Microsoft Remote Desktop (RDP) 10.2.1 insert or paste text error

While using the current version of RDP for Mac, it's not currently possible to paste or type text that includes capitals, or other letters that require a modifier key (ie. shift, control or option keys). If I choose the option for typing text it will translate something like "Fall@2018" into "fall22018". If I use Paste Text option I only get the letter v. And for "Paste specific items" getting copied to the clipboard, then adding an additional action to control v or command v I still only get the letter v as the output.

I'm currently attempting to use some TouchBar shortcuts for this but it also fails when using trackpad or keyboard shortcuts too. The option for typing text will translate texting like


  • Type of Mac: Macbook Pro (15-inch, 2017)
  • macOS version: 10.14
  • BetterTouchTool version: 2.645

I am having the same issue using magic trackpad 2 on IMAC when entering text to Internet Explorer Windows 10 on VMware Fusion 8.5.10
Normal functionality when entering into Safari in IOS 10.13.6

I have the same issue. I can't get "type text" to work over RDP using Microsoft Remote Desktop. It doesn't matter if I choose "Insert Text by Typing" or "Insert Text by Pasting".

Normal pasting (Ctrl-V or Cmd-V) works fine. And I can also type text if I use the windows layout on the keyboard (I have to press right alt key/Alt Gr + 2 to get a @, it wont work with left alt key + 2).

Are there any work arounds for this issue?

Microsoft Remote Desktop 10.6.8 (1914)
BetterTouchTool 3.570 (1710)

Imprint | Privacy Policy