Mic/Moon key on Sonoma

Hi, After upgrading to macOS Sonoma, my shortcuts tied to Mic Key and Moon Key on mbp2021 stopped working. I updated BTT to the latest alpha, but that didn't solve the problem. Really want my shortcuts back :frowning:

is maybe secure input enabled for some reason? (BTT will show a warning about this when clicking its menubar icon)

no, secure input disabled for sure. I checked this.
I also can't record new shortcuts with buttons like F3 F5 etc

I just checked, but there are not changes that would affect these keys in macOS Sonoma. Have you tried to restart your Mac?

One thing that's important:
"Always use old keyboard implementation" must be deactivated if you want to use these special keys:

yes I restarted my mac multiple times.
old keyboard implementation also deactivated
unfortunately I still can't add this moon key or mic key to shortcuts(

I can only imagine it's some weird permission issue, these often happen after upgrading macOS.
I would try to remove BTT from all panels in System Settings => Security & Privacy. Then add it again (deactivating may not be enough, really remove from the list)
It should not appear in "Input Monitoring", however it must appear in Accessibility.

Hi Andreas, I (sadly) have the same problem in Sonoma (magnifier / mic buttons) – I did everything you suggested but still no luck :frowning:

Could you maybe look into this agin (if you've got time)? I'd gladly supply more information if you need something.

Thank you!

THANK YOU! Your advice was helpful, problem fixed

Update: After re-assigning the buttons in BTT it works now … no idea what happened during the Sonoma update …

1 Like

Ah that's interesting, possibly the internal codes for these Apple specific keys changed with the update.

1 Like

how did you solved i have the same issue

have you tried recording the keys again?

Recording the keys again worked for me too!

I tried all the above-mentioned solutions and only re-recording the keys worked.