Menu Bar items are black on black for some reason

Describe the bug
The menu bar is frequently displaying menu items as black on black. I changes depending on what space I'm in (I think).
I'm not 100% sure this is a bug but nothing I do can get the menu items to invert back.Quitting bartender has no effect. Neither does toggling on and off "make whole notch bar black"

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

3.889 (2043) but has been happening for a while.
Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

this happens if you use a light desktop wallpaper, unfortunately BTT currently can only „forward“ the menubar icons the same way as they are displayed on the standard macOS menubar. (and macOS makes them black if a light background is used)

I’ll soon add sole detection logic to automatically invert black on black icons.

Ah I see.

Will the new logic mean auto-darkening for full screen; i.e when I want to watch a movie?

That's not related I think, but I will add this as default behavior soon (go black if video playback in full screen mode is detected)

Amazing! Thanks.

It seems I have a similar problem, but it is connected solely to my recent update of BTT. Everything worked great. But after attempted update, I got an error, then it seems I installed the update, but the top menu bar is all black and I do not see anything there. Only right clicking helps find the app icon I need. Now I have to refrain from using BTT.
I have M1 Macbook Pro, latest OS 12.6. Not using dark theme. I didn't change any system settings. It's the update that broke the top bar.

Right click the bar and choose "Hide Notch Bar", it was a bug in a version released today.

Thank you @Andreas_Hegenberg ! I noticed that there is a green dot now on the BTT icon in the menu bar. Why is it? Usually those dots mean that the app is watching or listening. But I didn't give permissions to screen record (only accessibility permissions) and BTT has no access either to a camera or mic...

oh, so I will have to do it every time I turn on my laptop (go out of sleep mode)?

no you can then access the BTT settings and disable the Notch Bar feature if you don’t use it!
No need to hide every time

Right, thank you , Andreas! For the answers and amazing tool. I can see that it's customisable, but I'll wait when it will be easier to customise and easier learning curve :slight_smile: So turned off for the time being.

Yeah the updates are fast and furious and I love it.
This isn't your problem at all but FYI I can't really get into the preferences of Bartender when I'm using better touch tool.
A right click normally does it but I only get the bartender prefs.

That's true, I need to add a way to show the original right-click menu. Will add that soon!

This issue started to appear once I updated macOS to Ventura. Is there any workaround?

This is how it looks now. The underlying, native menu bar is showing white icons, but with the BTT overlay - they are black. I tried setting the background to be black/what - it didn't help.

Any ideas on how to fix this?

This is on version 3.952

I spent the last month trying to chase down this issue! It never occurred to me that BTT might be the "culprit". I have two monitors—neither one sports a notcch—and the menubars were wonky. Finally did identify BTT as the cause, came here to report it and noticed this comment about the notch bar settings.

Which were enabled by default.

Andreas, you might want to consider changing that default. Thanks!

are you sure you were running a current BTT version? Basically the Notch Bar should never show unless you have configured at least one trigger in the Notch Bar section.