Menu bar clocks stopping with active Notch Bar (Mac OS Ventura)

every time I start the Notch Bar the Mac OS System clock in the menu bar is stopping. This happens to the clock of iStat Menus as well.
As soon as the Notch bar is hidden, the clocks are running again properly. (Restarting the Mac doesn't help).

  • MacBookPro 14"
  • Mac OS 13.0.1 Ventura
  • Better Touch Tool Version 3.952

Thanks for any help


I'm experiencing the exact same thing on my MacBook Pro 16" (2019), Mac OS 13.0.1 Ventura and Better Touch Tool Version 3.962.
Any chance of a fix in the near future?

Are you sure it stops completely? Or does it not update as frequently as it should?

It freezes for several minutes. I have a multi monitor setup. It's updated when I switch from an app on one monitor to an app on another monitor. But if I "stay" on the same monitor the clock is not updating. If switching to an app on the same monitor it updates but then stops again.

Is the clock then not updating on both monitors, or is it updating on the one and not on the other?

Neither one. It's only updating the clock when I switch apps. When I stay in an app it does not update. Forget what I wrote about multiple monitors. It's the same when using the MacBook without external monitors.

Weird. I'll try to reproduce this.

For now you could workaround it by disabling the clock in the status item widget and then placing the date/time widget in addition to the status item widget.

@Andreas_Hegenberg I had added "Mimic System Status Icons" as a user-defined item in the notch bar. At some point my system status icons were gone, and therefore I added it.
I've now tried to remove it again (since it was also enabled as a default item), and that seems to have solved the issue for me. Since I removed it the clock has been running fine for quite some time.

1 Like

I'm affraid the problem has returned :frowning: I don't know when and how it stopped working, but I'm back to the clock only updating, when I switch apps.