Magic Mouse stops scrolling

Describe the bug
The magic mouse will stop scrolling (one finger scroll) until either:

  • BTT is restarted
  • Scroll a little bit on the trackpad

After a while, the scroll will stop working again until I do one of the above.
Scrolling works fine if BTT is not running.

Not sure if its caused by an application, but the ones I'm using are:

  • IntelliJ
  • Chrome
  • Safari

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Magic Mouse

Device information:

  • Type of Mac: MacBook Pro 2018
  • macOS version: 10.14.3
  • BetterTouchTool version: 2.709 (tried stable and alpha channel)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
N/A

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Maybe you accidentally disabled single finger scrolling?

image

1 Like

Nope, the scrolling just stops working until I scroll with my trackpad or restart BTT.

Bug
Same here. Single finger scrolling isn't working in google chrome wenn BTT is running.
On all of my macs. Already disabled all plugins in chrome.

Two Finger scrolling is working, "disable finger scrolling" is not active

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Magic Mouse

Device information:

  • Type of Mac: MacBook Pro 2013 and two others
  • macOS version: 10.14.3
  • BetterTouchTool version: 2.714

Additional information
Problem started on each MacBook after the BTT update.

Are you really sure you don't have a app specific scrolling block for Chrome?

i'm really sure. it's scrolling only a few lines from time to time. every other app is scrolling smooth.

The issue I’m having is that the mouse scrolling STOPS working, not that it doesn’t work at all.

I’ll be in IntelliJ, everything is working fine as it should including scrolling, then all of a sudden the scrolling stops.

Then I have to either scroll with my trackpad just a little or restart BTT, then the scrolling with my magic mouse works again.

Does it affect single finger & two finger scrolling on the magic mouse?

Could you maybe check what happens if you disable these checkboxes? Maybe there is an issue somewhere with the swipe/scroll handling in BTT:

Oh and it would be really good if you could go to the about tab and click the "Export debug information" button. This will create a folder called BetterTouchToolDebug on your desktop, that should allow me to reproduce the issue. (andreas@folivora.ai )

@dru how often does it happen in your case? Is it completely random or in some specific app? If possible please also send me that debug data.

I'm back again. It only affects one finger srolling. I use now two fingers and so it works at least. Disabling these checkboxes has no effect. I will export my informations.

@Andreas_Hegenberg Thanks, I have emailed you the debug information.

The issue just happened right now, and it happens quite often per day, there doesn't seem to be an amount of time before it happens.

I have noticed it only really happens with JetBrains products, the one I use the most is IntelliJ but I do also use DataGrip.

^ Actually it's happening on chrome too, maybe I only notice it with IntelliJ because I use it the most.

Unfortunately I haven't found a problem in your setup yet and so far no other reports of a similar issue ;-( (For @ovit there was a database issue which caused two master presets to be enabled, which then lead to the scrolls being blocked due to a conflict between the presets)

Can you maybe think of any mouse related app that could conflict with BTT?

Hi @Andreas_Hegenberg, I'm still having an issue with this.

So I've boiled it down to:

  • Dual screen setup (2nd screen is bigger than MacBook)
  • MacBook is the main screen

When the main screen is the second monitor, I don't get the magic mouse scrolling issue.

Quitting or restarting BTT definitely sorts out the issue.
When BTT is not running, I have no issues at all.
Doesn't matter what app I'm using - its just happened in VS code.

I have the latest version of macOS and BTT.

Have the exact same issue.

Had the same issue. The problem was one of my active profiles had "single finger scrolling disabled", as described in this post Magic Mouse stops scrolling

However, the global master preset did not display this setting as enabled. Double check that all of your active profiles don't have the "single finger scrolling disabled" option checked.

Had the same problem. I only have one app for touchbar - after much searching I found 'Disable Single Finger Horizontal Scrolling' connected to my touchbar app. Not sure why that should automatically happen.

Imprint | Privacy Policy