Magic mouse odd behavior in ArchiCAD


#1

Describe the bug
In ArchiCAD (3D drafting program), there is a weird delay where, after selecting an item by clicking it, the item starts to move as though you had clicked it again. I have confirmed that disabling BTT solves the problem, but then I can't use middle click functionality. This has been happening for a few months now, and I'm not sure if it's related to an update in BTT or an update in ArchiCAD.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Magic mouse

Screenshots

Device information:

  • Type of Mac: iMac 27-inch, Late 2013
  • macOS version: 10.13.6 High Sierra
  • BetterTouchTool version: 2.645

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.


#2

I've been having the same issue for a while. MacBook Pro 2018, all OS updates, BTT Updates & ARCHICAD 22 updates installed.

It's the same in ARCHICAD 21 - so I suppose ARCHICAD isn't causing the issue.
If I click very 'briefly' it doesn't seem to occur. Adjust click-speed/sensitivity does not make a difference though...

Very annoying, since I mainly bought BTT for daily use with ARCHICAD.

FYI: for testing purposes, a Trial version of ARCHICAD is available at www.myarchicad.com


#3

You could try to disable window snapping for Archicad, some apps don't support the necessary API's correctly which could cause such issues:

image


#4

Great! - This seems to have solved it - I wasn't able to reproduce the error since I changed this. I'll post back if it occurs again.