Magic Mouse 2: Middle Click does not work

Hi,
I'm new to BTT and just bought a license.

I'm using it with Catalina (latest version) and my Magic Mouse 2.

The middle click does not work. I tested that in the 3D modelling software Sketchup and in my Browser Firefox.

I restarted the MacBook Pro. Nothing changes.

Screenshot:

The so called "Touch Live View" does not work neither.

Please, how can I get the middle click to work?

Thanks.

Is there really nobody who could reproduce the described behaviour?

I hope there's a solution.

Thanks : )

I fixed the live view button in the latest alpha.

However the single finger middle click on the magic mouse is pretty fragile as the touch area is not very big and the single finger gestures are already reserved by scrolling and left/right clicks, which BTT needs to workaround. Increasing the middle click area can help though.

Personally I'd recommend to use something like three finger click and assign middle click to that.

Thanks for your answer, Andreas.

I tried to increase the area for the middle click my moving the left slider to the left and the right one to the right.
Still I can't get the middle click to work.
I tested in Firefox and Sketchup Pro 2020.

The single finger middle click is very important for me, because I need it for 3D modelling. And I'm very used to it.

Is there any way to narrow down that the middle click does not work?

is it configured like this?

Thanks, Andreas.

I didn't know, that I have to configure it like that. Now it works!

Where can I can I download the alpha version please to try out the "touch live view"?

Please allow me another question.

What is the correctd way to configure BTT to perform a combination of a middleclick and a held shift key?

Do I have to configure the trigger "two finger click"?

And:
Is it possible to configure BTT that you start with a middleclick and - after that - tap with a second finger at the right to perform a gesture?

I like to rebuild the behaviour of Sketchup.
When you middleclick there, hold it, and press the shift key on the keyboard after that, the function changes.

When you still hold the middle zone and release the shift key on the keyboard, the function changes again.

My wish is, to perform that behaviour without the keyboard.

Imprint | Privacy Policy