MacBook Pro + Catalina + BTT = Computer Crashing

Hi,

I upgraded to Catalina the other day, and from that point forward, when BTT is enabled, my computer randomly crashes and restarts. Happens when I'm using the computer (everything freezes then reboots), or when I'm not, and return to see computer has restarted. Doesn't seem to happen when BTT is disabled.

The error I get is "BAD MAGIC! (flag set in iBoot panic header), no MacOS panic log available" (see attached)

Are there other reports of this? Any suggestions? I've attached a what may be a crash log from console, but I'm not entirely sure if it's the right thing.

What I can ascertain so far is that crashes don't happen when BTT isn't running.

Thanks,
Matt

BetterTouchToolScriptRunner_2019-10-10-133533_MeltzBookPro.wakeups_resource.diag.zip (5.3 KB)

Untitled|625x500

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Screenshots
If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Hey,

this is most likely a hardware issue and probably related to the Touch Bar. It might be triggered due to BTT's Touch Bar usage, but the underlying issue can not be BTT (BTT works as a normal user application without kernel extensions)

You might want to have a look here: https://forums.macrumors.com/threads/2018-macbook-pros-crashing-with-bridge-os-error.2128976/page-145 there are quite a few people that encountered such issues with the Touch Bar (regardless of BTT) in the past.

There haven't been similar reports here though so it doesn't seem to be a super common issue - I'd still try to get it replaced by Apple.

Thank you. I'll look into it.

I have Same Problem. mbp2018 10.15 When I open and want to login in agin use fingerprint

Sorry, solved.

Same problem here. My computer immediately shut down when I plugged in my 3 monitors (USC-C).
I also had the error: "BAD MAGIC! (flag set in iBoot panic header), no MacOS panic log available"

Note that I'm using a customized TouchBar. I will keep you updated if I get more inputs.

Guten Tag

Ich habe das selbe Problem, gibt es da schon ein Lösung? Ich habe BTT gelöscht und die neuste Version auf folivora geladen. Es funktioniert trotzdem nicht. Die App lässt sich nicht starten.

I also have that problem with a brand new 2019 Macbook Pro and original catalina macos installation.

Especially with USB hub and 2 monitors connected, this happens almost every time when MBP tries to show login screen after screen lock.

most likely a hardware or driver issue! Have you fully update your catalina installation?

+1 , 2019 macbook 16''

every time after 25 minutes sleep

Yes, I have installed all recent updates, nothing has fixed it yet.

There are tons of people with these errors on the Apple forums. (https://discussions.apple.com/thread/250826263).

According to these threads the only real solutions seems to be a logic board replacement, although some people apparently were able to fix it by reinstalling macOS. (I also got the 16" MBP, luckily no problems here)

I have this issue. I have BTT. BTT was not running while I've experienced the issue. Just wanted to update.

im also using MBP 16, sadly I had this issue.

will crash and can't login after sleep...after uninstalling BTT, everything back to normal.

I'd get a replacement while you are still under warranty. (But I have heard that the upcoming macOS 10.15.4 is supposed to fix these issues)

u mean get a replacement of MBP from apple? hope 10.15.4 can fix this problem...(I can't live without BTT, but crashing every time is really annoying... :sleepy:

Yes, get a replacement from Apple. According to many people on the Apple forums this is a hardware issue (while it might be triggered by BTT the underlying issue is not BTT, it also happens with various other apps)

Imprint | Privacy Policy