Mac menu bar missing when starting BTT?


Newbie here and been tinkering around in BTT for a few days and suddenly today I find that my mac menu bar at the top is missing when BTT is open. Here are some screenshots showing the problem happening when BTT is open. Weirdly enough when I press the BTT application once the Mac menu bar disappears then I have to press the BTT app on the dock once more for it to show up. The menu bar comes back after quitting BTT.

Screenshot 1 - Normal workspace. BTT not open.

Screenshot 2 - Pressed BTT application on dock once. Menu disappears. But BTT doesn't open.

Screenshot 3 - Pressed BTT application one more time then it appears. Menu above still gone.

Screenshot 4 - Right click and quitting BTT. Mac Menu bar reappears.

I'm not sure if I triggered something in the BTT menu beforehand. I also tried checking/unchecking the "Show menu bar icon" in the settings but it didn't work. Hope you can advise on this. Thank you!

Mac OS 12.3.1 and restarted few times to test.
BTT items in my list being used - Trackpad, keyboard shortcuts, key sequences, and automations.
I haven't tried uninstalling/reinstalling BTT yet. Will I lose my presets?

Having this same issue. macOS 12.4.

This happens if you have used / played with the Notch Bar feature but not added any buttons to it. Scrolling over the black bar will show the menu items.

If you are not using the Notch Bar feature, best disable it in the BetterTouchTool settings.

1 Like

Solved. Thank you!