M1 Mac & Trackpad, Disappearing laggy Pointer

On my new M1 MacBook Air the pointer is laggy and stuttering or jumping, sometimes the pointer completely disappears and only comes back after swiping to another virtual desktop.

In graphic intense Applications the pointer at first hangs a few ms when drawing and then draws.

When I disable BTT everything works fine, no stuttering, jumping or disappearing pointer, no lags in Graphic Applications.

Device information:

  • Type of Mac: MacBook Air M1
  • macOS version: Big Sur 11.1
  • BetterTouchTool version: 3.553 (1693)

Bump! Nearly a month after post.

fortunately I haven’t encountered anything similar on my m1 and haven’t had similar reports yet.

Do you have any of the experimental sync options enabled in BTT (Dropbox / iCloud)? If so, try to disable them.

No I haven’t. It’s mainly window snapping I use on that machine and a few keyboard shortcuts, nothing uncommon.
I think I try to disable them one by one and see what function exactly causes the problem.

Is this only happening in specific apps? (Some apps might not handle the APIs for Window Snapping correctly, in that case you can disable window snapping for specific apps)

Not that I know. It happens on Finder and definitely on some graphic Apps.

Ok, Finder definitely shouldn’t cause issues.

You are sure this goes away immediately if you quit BTT?

Yes. On Finder the pointer suddenly disappears and then comes back a few cm away.
As soon as I disable BTT the problem is solved.
In graphics Apps I begin to paint, and the pointer begins to move after a little lag.

Today I send the device back to Apple for exchange cause I have battery issues. When the new one arrives I‘ll test again.

I've got my new MacBook Air a few days ago and installed BTT 3.553 (1693). I only set up window snapping and a 4-finger-tap gesture, but the problems as described in the original post are still there.
The Finder hangs a lot of times, I move my finger but the pointer stays where it is and in some Apps the pointer is reacting very laggy. In this case I tried it with Wonderdraft (Rosetta), not sure which other Apps are affected or if this is specific to Rosetta. On my Intel Mac I don't have these problems.

I've recorded the behavior on my machine. On the video it's less visible than in reality, but I think you can see what I mean.

https://www.dropbox.com/s/b2nuyfmkx2aa4e4/btt_laggy_m1.mov?dl=0

Problem still exists and is reproducible with current version 3.562 (1701)

Imprint | Privacy Policy