Lost settings with installing version 2.807

Describe the bug
I lost my configuration after installing latest version of BTT (v2.807). I just clicked "yes" on the prompt whether I want a new version. Now I get "You have not yet configured actions in BTT" on TouchBar and my keyboard shortcuts don't work anymore.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
TouchBar, kbd shortcuts, i.e. all I have configured.

Device information:
MacBook Pro '18, 15', macOS 10.14.4 (no recent updates), BTT 2.807.

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Tried to move files around in ~/Library/Application Support/BetterTouchTool with no luck, restarted BTT & system. I used to have a completely customized TouchBar and a couple of kbd shortcuts + key remapping.

Could you send me the contents of that folder to andreas@folivora.ai? I'll probably be able to extract your setup.

Thanks Andreas, just did so.

Solved via e-mail.

BTT seems to have been confused because you apparently once used version 2.749 but the version you actually used was 2.717. It migrated the settings from 2.749 because it thought it was the latest used (unfortunately these settings were empty).

1 Like

Thanks Andreas! Awesome support! :slight_smile: