Lost all presets after deleting SetApp (edited)

Describe the bug
I was trying out SetApp for a little while and downloaded BTT through it. After uninstalling SetApp it deleted the preferences associated with my personal BTT app.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: 2016 MacBook Pro 15in 2.6 GHz Intel Core i7
  • macOS version: 10.13.5
  • BetterTouchTool version: 2.513

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Sorry I can not influence the behavior of Setapp. Could you check whether the ~/Library/Application Support/BetterTouchTool folder is still there? (the tilde means this is referencing the Library path in your user directory, you can go there by clicking Go => Go to Folder)

Unfortunately none of the settings are there. I’ve been in contact with SetApp support and they sent me the following: “In Setapp, we recommend our vendors to use a separate Bundle ID for Setapp versions of their apps and store preferences and user data separately from data created by individually licensed versions. The reasoning behind this is to prevent such unpleasant situations. We'll be raising an issue with the devs of Better Touch Tool to get this fixed.” Hopefully they did end up getting in contact with you?

Just had this happen to me, deleted SetApp and it erased my BTT settings. I have constant Time Machine Backups that occur. Do you know if is possible go back and grab the settings file before it was deleted and where that location is at that the settings file might have been stored? I can restore the entire SetApp installation as well if need be.

the settings are located in ~/Library/Application Support/BetterTouchTool (it's an invisible folder, to show invisible files in Finder press shift+cmd+dot

The ~ means "your user folder"

Btw. Setapp should now ask whether it shall delete the data of installed apps. Didn't it do that?

Yeah I checked there, I didn't see any .bttpreset files in that location in the Time Machine backups. Is it another file I'm looking for?

Also, yes Setapp did ask me and I chose to delete the data, because I honestly don't remember installing the BTT app through Setapp. So, I can't comment whether or not it was just user error (not remembering I installed it one point if I did) or if Setapp erased app settings outside of it's domain. I would assume the former :slight_smile:

easiest would be to just restore that compete folder. Bttpreset is only used for sharing, internally BTT uses a different database format.

That worked! Everything is back. Glad it was that simple... Making an explicit backup of my settings now! Luckily my tweaks are just variations on top of all the great work from GoldenChaos' setup!

Really appreciate all the work you've done on this app man!