Lingering effect of keyboard sequences commands

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Basically after I created keyboard sequence it was working erratically. Moreover even when I disabled the sequence, it was somehow still working (still erratically). It only stops if I completely quit BTT.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")
    MacBook Pro 2022
    BTT 4.272

Additional information (e.g. crash logs, related issues, etc.):

I also have this (esoteric :upside_down_face:) experience from time to time. I can't prove it, but I think I recognize two cases.

  1. A deactivated trigger still works.
  2. A deactivated trigger does not work, but it prevents another one from working that was set up afterwards.

(1) is very rare. (2) much more common. Only complete deletion helps. Both cases are very difficult to reproduce because it is unclear to me which criteria are decisive. However, I can say with a fair degree of certainty that variant 2 mainly (perhaps only) affects triggers where the Advanced Conditions are also set.

In the meantime, I know roughly where to look and what to delete if something doesn't work. But if you're not aware of this problem, you'll find that certain things don't work for no reason.

I know, unfortunately this doesn't help anyone :wink:

4.376 alpha should fix the issue where deactivated key sequences are not really deactivated!

Thanks :green_heart: