Left Click not working

Been dealing with this for months. I set a new shortcut, it involves Left Click, and it will work for a few days, then stop. I restart the computer, restart everything, disable any Logitech drivers etc, grab a new mouse, put it in a different usb port. Persists through updates, I even reinstalled MacOS recently and it persists.

The "Double click" command works fine. I sometimes think it just moves too fast, so I put in delays, but that doesnt always solve it either

Regular mouse

Device information:

  • Type of Mac: 2015 Macbook Air
  • macOS version: 10.14.6
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.346 (1554)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):
Workaroumd: use double click command

wait, what exactly are you trying to do? how does your setup look like?

Well I tried to upload log but it wont accept the file type. :roll_eyes:

Im working in an app, and i want to push F2, and have the mouse go over there, click that, type the # key. Thats all. Its a way for me to quickly tag something, so I can race down my list faster. It worked for a few days. But now it goes over there, doesnt click, types the # key. Unless I push F2 a second and third time. By the third time It will click. And now i have a mess of hashtags everywhere

And for the record, since I bought this app maybe a year ago(?) this has been my experience with every left-click shortcut I try to make. They will work for a day or three, just long enough for me to start forming the habit, then they disappear. Finally posting here means I already spent 20+ hours messing with it and googling it.

Most of the shortcuts I want to make are that simple. Push keyboard key, mouse go click that thing, then maybe click one other thing or type one key.

This setup works now that I added double click.

I am having this same issue.

The Left Click trigger worked for more than a year, until recently (last 3 months or so). Now BTT seems to be unable to perform the Left Click trigger.

The mouse will move to x,y position, do all triggers, but then skip the Left Click trigger, then go on to the next task. I have added very long (many second delays) to no prevail.

I have created many groups/widgets where the Left Click trigger is an integral part, and now all of these don't work because it skips this important trigger. I have also tried Double Click with no luck. I have spent so much time troubleshooting this and am in desperate need of assistance.

I seem to have found a fix.

Before the "Left Click" trigger, add Show/Hide Mouse Cursor, then Left Click, then Show/Hide Mouse Cursor.

So I will move mouse position to x,y > then Show/Hide Mouse Cursor (this will make the cursor appear) > then Left Click > then Show/Hide Mouse Cursor again (this will make the cursor reappear).

It only took a few months and I finally got it!

1 Like