"Launch App/Open File" stuck for 5sec but only first 2 times every time after reboot the BBT(2.685)

Describe the bug
I use "Launch App/Open File" to open Downloads folder in Touch Bar button, but every single times after reboot the BBT, it will definately stuck for 5sec but only first 2times when click Touch Bar button to open folder. version is 2.685.
Please help to verify.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Touch Bar

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Macpro 2018
  • macOS version: 10.14
  • BetterTouchTool version: 2.685

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Note: Before bug reporting, please make sure you have the latest version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

when using this action BTT just tells the system to launch a specific file / folder. Maybe something on your system is still blocking the open process? (e.g. some unreachable network drives that Finder tries to reach?)
There doesn't seem to be any delay on my machine.

Please check this video, seems not very obvious, but when restart BTT, click touch bar button, first 2 times take 5s+ to load the finder to open folder. But no issue after 2 times opened.
Per your idea I checked this is a new device so no network folder mounted, and no issue when just open finder (also no issue from BTT to just open Finder rather than open a specified folder).

Could you come into mind that any other luck can be tried?

Please check the update previous, thanks.