Keyboard shortcuts used to resize window not working

Describe the bug
Keyboard shortcuts using numeric and numeric pad used to resize window is not working properly. I have both my numeric and numeric pad keys setup to resize windows.
So for instance Cmd+1 and Cmd+(numeric keypad 1) would resize to bottom left corner.
This has been working fine until today, although I have not used my laptop for close to a week so not sure if it occurred under different BTT versions in that time.
What is happening now is that some of the shortcuts work and some don't and it keeps switching as to what shortcuts work, and instead of a resize a tooltip pops up now which never happened before. See below screenshot.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Macbook Pro numeric and numeric pad keys

Screenshots
Here is an example of trying to set the BTT config window to resize into the bottom left corner by pressing Cmd+1, where you see the tooltip popup, but no resizing occurs.


Device information:

  • Type of Mac: MacbookPro 15" 2017
  • macOS version: 10.14.5 and 10.14.6
  • BetterTouchTool version: 3.206 (1382)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

The screenshots are taken while connected to an external monitor with the laptop closed in clamshell mode.

Does BetterTouchTool show a warning about secure input being enabled when clicking the menubar icon?

While secure input is active, BTT can not capture FN keys modifiers (and the num keys always implicitly press FN). Thus the num key and the standard keys look the same and as you have defined them twice, BTT won't know which one to trigger and will show the selection popup.

image

Here is the screenshot of my BTT menubar, showing no secure input:

24

For clarification, when I set this up quite some time ago I only setup the number pad where I had been using an external Logitech keyboard. When I then opened up my laptop I found that the standard number keys did not work, hence the duplication of assigning the standard key shortcuts.

Thus the num key and the standard keys look the same and as you have defined them twice, BTT won't know which one to trigger and will show the selection popup.

Ok but if they're the same action, theres no difference so it doesn't matter which one to trigger in my case.

Just to be sure theres no ambiguity which one to trigger, even though they are the same action, I tried disabling the number pad keys for one of the shortcuts thus only having the standard number key enabled and it still doesn't work.

So something has changed in the last week or two, either i did something, BTT update, MacOS update, or other ?

My solution for the moment is to delete the number pad shortcuts, at least that way I can use the standard number keys on both the laptop and external keyboard. But it was nice using the number pad as it presented a nice visual picture for me where I wanted windows to go on my screen.

I will look into this. It's probably some weird bug.
I'm not sure what could have changed though, do you remember which was the last BTT version you had installed? (Maybe post the output of this terminal command: ls ~/Library/Application\ Support/BetterTouchTool, based on the data files I should be able to see what was the last installed version)

Imprint | Privacy Policy