Keyboard shortcuts stopped working

Hi,
I'm using the latest version 2.6 and for some reason, in the last days the keyboard shortcuts stopped working. The mouse shortcuts still work fine. Did anyone encounter this too?

They seem to be working fine here - could you maybe go to the about tab in BTT and click the "Export Debug Information" button? This will create a folder on your desktop called "BetterTouchToolDebug". It would be great if you could send that to andreas@folivora.ai

Same thing happened to me. Very frustrating. macOS 10.14.0, BTT 2.660.

I'm having the same problem, my debug folder is on its way.

If it means anything, I noticed that the BTT menubar dropdown says:

:lock: Secure input activated by: loginwindow (PID: 107). Limited shortcut functionality.

It certainly seems like we're suffering from limited functionality. :wink:

This is happening to me as well. Kind of a drag that BTT has not provided a solution or otherwise addressed here in the forum. This is crippling me in my work. Please advise.

I tried to toggle the OS security prefs for BTT without quitting BTT and locked up my whole system. Had to to a power-button shutdown & restart, but then the original error was gone & all is right with the world. So at least for me, if you see that "Secure input activated by:" message, just restart your whole machine.

:lock: Secure input activated by: loginwindow (PID: 107). Limited shortcut functionality.

Same thing started happening to my system too within the past month. I can't tell what exactly triggers this condition - but I suspect it has something to do with going in and out of sleep etc. I don't think this situation ever occurs mid-stream when you are working with your system.

Regular logout or restart seems to take care of it.

Any non-destructive (i.e. not be forced to log out of all sessions and apps) workarounds possible?

@Andreas_Hegenberg any way I can cooperate with you towards a resolution? Should I try exporting debug info next time this happens and send it along?

Not sure exactly when "Secure input activated" started showing up, but I don't seem to be able to get rid of it.

macOS 11.3 Beta (20E5217a)

habe you tried to quit / restart Safari?

Huh...that worked...for the time being, anyway. Thank you! BTW, I've also been struggling to understand why BTT keeps spontaneously going into "Disabled" mode. It happens randomly, as far as I can tell. Any ideas?

1 Like

Do you have a shortcut configured to disable BTT? Or did you maybe configure it to be disabled for specific apps? (click on an app in the left sidebar to see)

Thank you for your reply. I certainly didn't intentionally create a shortcut to disable BTT... Nor did I intentionally configure it to be disabled for any apps. Of course, I may have done something wrong somewhere...

BTT spontaneously disabled itself for all apps yesterday.
Thanks to this post it was quickly fixed.

Having to quit applications and/or reboot the whole machine to work around a deal-breaking-disruptive, long-standing bug is bs. BetterTouch has been an extremely important part of my workflow for years and I just find it unbelievable that all you can tell users with this issue is "have you restarted x?"