Keyboard shortcuts issue (arrows or tab repeated and/or delay required)

The Bug :

I have a new issue with BTT since buying a new M2 Macbook.
I don't have this issue on my other work Macbook nor did I have the issue when using previous home Macbook.

The issue is regarding random behaviours when assigning a keyboard shortcut action to be used by themselves or in a list of actions to be triggered.

The example that is the most striking in my daily use would be adding an ARROW key (left, down, up, right) or the TAB key. Those are part of a lot of my triggers when having to select options from pulldown menus for example.

For some reason, when using the arrow key or tab key in Chrome, it doubles some of the arrows or tab shortcuts.
One arrow would sends two arrows, two arrows would send three, three arrows would send five.

The issue does not seem to be reproduced in other apps.
I tried in the Notes app, and three arrows were three arrows.
However, the created shortcut would not work at all in Notes unless I added a short delay before the first arrow.

It also only seems to be affecting the arrows and tab keys.
For example, if my trigger in Chrome is assigned to send a LETTER A keyboard shortcut, then LETTER B, then LETTER C - it would be written ABC (but requires a delay to be working).

**Affected input device : Keyboard shortcuts.

**Screenshots and movie ( I hope it helps !) :

Device information:

  • Type of Mac: MacBook Air M2 16GB

  • macOS version: Ventura 13.5.2

  • BetterTouchTool version: (please post the exact version - not just "the latest one") 4.273

I also have issues with keyboard shortcuts after updating to 4.272

@Andreas_Hegenberg any ideas on what could be done to fix this ?

This issue has unfortunately made my BTT unusable for me (impossible to choose options from drop-down menu, or to go through boxes with tab).
And I am convinced the issue is not my MacBook given it is fresh out of the box.

Crossing my fingers that you will answer my thread as I use BTT all the time for work.

Thanks in advance :slight_smile:

unfortunately not yet, I tried the shortcut sequences you mentioned but they seem to be working fine here.
Do you have any other keyboard related app installed?

Are only existing shortcuts affected or does this also happen if you create new ones?

Thanks to your suggestion, to test out if any appIications could be interfering with BTT, I tested a fresh BTT install in a newly created user on my Macbook and it was working just fine.
It still had issues working well on my regular user when quitting all processes and apps.

I ended up deleting BTT and all presets/triggers.
Then redownloaded BTT and only imported triggers without presets.

For some mysterious reasons, everything is working just fine now.

Thanks again for taking the time to answer.
I wouldn't be able to fonction without a working BTT eheh !

Have an amazing day !