Keyboard shortcuts are not working

Describe the bug
The keyboard shortcuts do not work. For a long time I have created a keyboard shortcut ⌃⌘V, which opens the clipboard history. Unfortunately, it doesn't work either when using the on-screen keyboard versus the physical keyboard. So I created several other shortcuts that are also unresponsive. The problem has been occurring since the last update, just before the update I was using shortcuts and there were no problems.


Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard


Screenshots


Device information:

  • Type of Mac: MacBook Pro M2 Pro
  • macOS version: Sonoma 14.2.1 (23C71)
  • BetterTouchTool version: 4.401 (44010)

Additional information (e.g. crash logs, related issues, etc.):
I tried to revoke and assign Input monitoring (or a similar name; sorry, but I use a MacBook in Polish and I don't know how this permission is called in English) and Accessibility permissions, but it did not help. I restarted the application and the entire computer.

that is weird, I don't think there have been keyboard shortcut related changes in that version (and more than 10k users have already updated to 401). So I don't think it's a general problem with keyboard shortcuts.

Is BTT in maybe disabled?

Maybe go to Help => Export Diagnostic Debug Information and send the result to andreas@folivora.ai, then I can check what's going on!

When you wrote this to me it reminded me of one thing - I checked in the settings and only when I enabled this function it fixed itself. I have no idea what the issue is.

did you in the past also use the onscreen keyboard? I remember that this has caused issues in the past. (but mostly with window snapping)

Does BTT show something about „secure input enabled“ when you click the BTT menubar icon?

I've been using the on-screen keyboard since the beginning.
I checked and there is nothing about secure input.

one other thing, you mentioned BTT is listed under „Input Monitoring“ in System Settings? It should not be in there, only in Accessibility. Can you try deleting it from Input Monitoring?

I removed. Still, it doesn't work with disabled old shortcut implementation

Very strange. Sounds a lot like a permission problem because without the right permissions the new keyboard shortcut implementation is not able to capture keyboard events.

It could also be another app that captures the events before BTT.

Would be great if you could send the debug logs, maybe I can see what's happening.

I sent via Mail Drop because the attachment was too big.

Unfortunately nothing in the log or config that would explain the issue ;-(
Your shortcuts work with that exact config on my machine.

Possibly try to reset all permissions for BetterTouchTool via this terminal command: (quit BTT first!)

tccutil reset All com.hegenberg.BetterTouchTool

Can you maybe think of another keyboard/mouse related app you recently installed or updated?

Still doesn't work, and after running BTT, it asked me for „Input Monitoring“ permission.
Only apps that can be related with keyboard or mouse are Karabiner and Logi Options+, but I'm using the first one for 2-3 years and right now it's turned off and second one I'm using for a few weeks, but problem started a few days ago.

Right now, I found another problem - I can't use single finger force click, but two finger tap is working.