Keyboard shortcut with condition no longer working

Describe the bug

Some of my old shortcuts no longer seem to work. Not sure when this started happening, might have been in the last few versions?

In particular, I have a shortcut that triggers a named trigger, with a condition on it:


The 'advanced conditions' screen implies that the condition should be met, so shouldn't prevent the trigger:

I have tried both with the 'add small delay' option on and off, and doesn't seem to make a difference:


Looking at the 'Recently Used' section, it claims that the shortcut is being triggered, even though nothing happens:


As an example of what a similar shortcut looks like in 'Recently Used' when it works correctly, it should seemingly show the key trigger, and the named trigger:


As a sanity test, if I duplicate the trigger, remove the condition, and disable the old one, it seems to work correctly:


Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

Magic Keyboard


See above.

Device information:

  • Type of Mac: MacBook Pro 16" (2019)
  • macOS version: Ventura 13.6.3
  • BetterTouchTool version: 4.467 (alpha)

Additional information (e.g. crash logs, related issues, etc.):


In case it's helpful, those above shortcuts are defined in a conditional activation group.

I also have the same shortcut (without a condition) in the 'For All Apps' section:


This works for most of my 'normal' apps, but doesn't get triggered in this app because it's presumably shadowed by the one in my conditional activation group (as expected).

The condition is set on the broken trigger to help differentiate it from these key sequences:


(this pattern has worked well for quite a while, until relatively recently)

thanks for reporting, this is probably an issue with the latest alpha version. I'll have a look!

1 Like

I think this should be resolved in 4.468 alpha

1 Like

I believe I was on a general release version when I first noticed it (unless I was unaware that I was on an alpha release); I just updated to the latest alpha as per the reporting instructions.

Just updated to 4.468, still doesn't seem to be working unfortunately; same symptoms as above.

ah then it might be a different issue. Could you go to help -> export diagnostics debug information and send the result to me? (

1 Like

Sent :slight_smile:

I think this should be working again in 4.469 alpha (seconds_since_last_trigger was problematic)

1 Like

That seems to have done the trick! Thanks! :slight_smile: