Key Sequence doesn't record typed letters (only records control, command, option, etc keys). App obtained through Setapp.

I am trying to create a typed key sequence, however "Key Sequence" doesn't record typed letters (e.g A 7 Y) (only records control, command, option, etc keys). App obtained through Setapp.

MacBook Pro, OSX Mojave

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: Mid 2015
  • macOS version: Mojave, 10.14.3
  • BetterTouchTool version: 3.096

this probably means that either BTT doesn't have the accessibility permissions in system preferences -> Security and Privacy or that some app enabled secure input and didn't disable it afterwards. Does the BetterTouchTool menubar item show a warning after clicking it in the menubar?

Hi, Permissions all set properly indeed. I suspected sandbox issues as this is an app within setapp. I have uninstalled setapp and installed standalone trial of bettertouchtool and all worked great. However, when I reverted back to setapp same problem occurred.

setapp doesn't have a sandbox :man_shrugging:. I'd try to completely remove the permissions from System Preferences -> Security and Privacy -> Accessibility, then add the setapp version back there.

In fact I did try adding setapp permissions as you suggested but that did not help either. Actually, I forgot to mention that when I installed bettertouchtool I got the same problem and had to use AppCleaner to completely uninstall bettertouchtool. Then downloaded the trial and installed it, that solved the issue for me.

Hi there. I'm appearing to have the same issue as the OP. Please forgive my ignorance but your suggestions on resolving the issue aren't clear to me. Can you please kindly confirm steps required to resolve this issue?

I'll get us started, can you please confirm if I am correct and/or reply with edits/additions to my steps?

  1. disable BTT permissions in global OS system preferences accessibility settings,
  2. save and export BTT settings,
  3. uninstall BTT,
  4. uninstall Setapp,
  5. re-install Settapp,
  6. re-install BTT,
  7. provide BTT access in global OS systems preferences accessibility,
  8. import BTT settings profile,
  9. create new key sequence trigger.

Do I have this correct? Hoping there is a more simply solution as this would definitely be a pain as it would also likely create issues for me with my already downloaded Setapp apps.