Key Sequence bug introduced in version 4.283

Hello there Andreas,

I'm facing a bug with Key Sequence. Since it really affects my daily workflow I've went through the process of downgrading until I find the build which introduced the bug. And here's my conclusion: the bug is present in all versions starting from 4.283 (included). And it isn't present in 4.282 and below. I'm staying on v4.282 for now but it's not a future proof solution... I'll try to describe the bug the best I can and reproduction steps.

Describe the bug
Here's the affected trigger:

This trigger (double click right CMD key) opens up application switcher. If key released, it jumps to the latest app (as the stock CMD + Tab does). If key not released, I can circle through apps using arrow keys (again, as the stock CMD + Tab does).
It was working perfectly, but starting v4.283, when releasing the key, the App Switcher doesn't dismiss, and doesn't bring the latest app anymore. It just stays stuck on screen. I need to press Enter to dismiss it.

The issue can easily be reproduced by creating this Trigger/Action and using version 4.283. If you don't use the keyboard for ~3 seconds, it will bug on the next trigger. And the exact same was working perfectly on 4.282 and below.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Key Sequence on MBP M2 Pro.

If it can help, here's a video of the issue:

Device information:

  • Type of Mac: MacBook Pro M2 Pro
  • macOS version: 13.5.2
  • BetterTouchTool version: tried up to 4.336, but currently sticking to 4.282

It seems to work fine here, did you maybe enable the "Use Gesture Mode" checkbox?

Ah, but your key sequence should look like this (otherwise it should only trigger when the cmd key is not pressed anymore):

I've just checked, I don't.
Have you waited a few seconds without touching the keyboard? I've confirmed that we need to not use keyboard for a few seconds for the bug to appear (as we can also notice on the video, it works fine when keeping the keyboard in use).
Without changing anything in my BTT config, it works fine on 4.282 (and below) and fails on all versions above this.

Ugh, I was in hope when trying this, it worked fine on 4.282, but I've just reinstalled the latest alpha and it fails :frowning:

Have you tried to edit your key sequence to remove the last "cmd up"? If that worked in the past, it was a bug.

It should only have three events,
cmd down, cmd up, and cmd down - no cmd up at the end

Actually you were right, it was it! I said it wasn't working in my previous response, but I've just actually noticed that my sequence was still the previous one, for some reason (whereas I've seen it without the last key after saving :thinking:). I've done the sequence again on the latest alpha, and it now seems to work consistently!

As you said, it makes sense that it should only include 3 events, and it might indeed be a bug that it was working in previous versions (I was using this gesture since the beginning of the year).

Thank you so much, I'm so glad to be able to take advantage of the new alphas again with conditions/loops and more! :muscle:

Glad it's working again! I'll definitely check why it worked on the previous versions, I didn't intentionally change it.

(However with version > 4.283, key sequences got way more powerful. Maybe something changed while implementing the new features there)

By the way, this also works nicely with BTT's window switcher:

Thanks for the suggestion! I've just set it up, and I'll see if I can get used to arrow up/down instead of right/left ahah.
For sure I'll keep BTT Switcher for another sequence: double right Option key which I was using to switch between the windows of the active app. Since MacOS doesn't have a switcher for windows, I was only able to switch between the 2 last windows. I've just changed the gesture to use BTT Switcher on active app, so now I don't have this limitation anymore!

Those triggers were already a life changer for me, and now they just improved even more! :smiley: