Issues with mac os Sonoma

After the update to Sonoma, I have some issues with Siri shortcuts, which I run from the context menu.
Whenever I run a shortcut, that contains an Apple script, it is not working correctly. When I open the shortcuts app to check and edit the shortcuts, I can no longer activate the context menu. I have to open the BTT settings and close it, in order to open the context menu properly.
I think it is more a shortcut, and Mac OS problem than a BTT problem, but maybe there is something that could be tweaked.

I also tested it out, and it seems that you can not activate the context menu when the Shortcuts app is running. And the shortcuts sometimes work fine, and sometimes they don't. So, I can not figure out where the issue is.

Does it work if you run it via this terminal command?

shortcuts run thenameofyourshortcut

Yeah, they work from Terminal.
Before I did that, I ran them from the Shortcuts app, and they seem to be working. That is very strange. Sometimes they work, and sometimes they don't.
At first, I put the command like this:
shortcuts run Mac Updates which didn't work. But then I put that before and after the name, and it worked ' '.

weird, I’ll try to reproduce later today!

Ok, thanks.
I also reported it on the Apple feedback site, so hopefully, it will be fixed soon.

could you maybe share one of them or do they contain sensitive stuff?

Yeah sure,
here you are:

and here is another one:

Hey @Andreas_Hegenberg,
A couple of days ago, I opened my MacBook and got a message that the control center needed permission to control the Mac, so I clicked the settings button to allow that. As I was there, I also gave Cliclick and Shortcuts Events permission, and by right-clicking on it, I also found the location for System Events and added it to that list and to the Input list. And since then, everything seems to be working again.
I don't know if that was the solution, but it seems to be working for now.

1 Like

Ah yes, that sounds like it was the cause!
Sonoma seems to have reset some permissions for some users. :man_shrugging:

Ah ok.
Yeah, that's weird.
The only issue, that still seems to happen is, that whenever I open the shortcuts app, I'm not able to 3-finger click to open the context menu, where I can start shortcuts from.

Hey @Andreas_Hegenberg. Whenever I maximize a window on Sonoma, the title bar of the window overlaps with the Apple menu bar at the top of the screen. The proportions are correct, but the whole window is positioned about 10-15 px too high, causing the title bar of the window to be positioned under the menu bar. This is happening in Vivaldi browser as well as Adobe InDesign. However, it is not happening in Spotify or Safari.

do you use multiple displays? If so, is there anything special about your setup? (maybe dock on the left/right or similar?)

@Andreas_Hegenberg I do use a MacBook Pro 15 with a side monitor, but the issue happens on all displays with or without the dock, even when the external display is disconnected. The issue also happens when I Snap the left-half or right-half position on any screen.

I‘ll download Vivaldi and check what’s happening

Hey @John_Nelson,
I'm also using InDesign, but the only issue I had was that whenever I double-click on any page from the pages panel, InDesign seems to think I'm trying to move the page and let it immediately go, which causes the typical beep sound.
But this issue sometimes appears, and sometimes it's not. I just tried it out, but this time, everything seems to be working just fine. :man_shrugging:
But now I have an issue that whenever a message is popping up, for example, if you close an unsaved document, you have to click multiple times in order to click on any button there.
Because of that, I disabled BTT for InDesign.
I also tried to minimize and maximize the InDesign window and that works fine.

Thank you for the insight. This makes me think it might just be an issue with my own Sonoma OS menu bar or dock settings.

1 Like

@Andreas_Hegenberg I restarted the BST app, and it appears to be fixed.

interesting! However there have been a few similar reports recently, so I assume there is some sort of issue. I’ll investigate.

1 Like

I think I have found the issue. A system API has started returning incorrect values for the menubar height.
I'm now trying to calculate that height manually in 4.276 alpha, haven't tested on all display setups yet.