Issues with getting the Process Priority Helper Tool installed

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug

The Process Priority Helper Tool will not be installed - even though the fact that BetterTouchTool is asking for Admin Privileges.

Tried latest Alpha, too ant the issue remains the same.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: iMac 2020 27 inch
  • macOS version: 12.7.3 Monterey
  • BetterTouchTool version: 4.403

Additional information (e.g. crash logs, related issues, etc.):

is there an error occurring?
Maybe check via Activity Monitor whether there really is no BetterTouchToolPrioWatcher process.

However on systems running macOS >= 12, I believe the helper tool will not have a big impact anways

Hello Andreas

Thanks for your quick reply ..

Just checked Activity Monitor - and what I see is strange … the BetterTouchToolPrioWatcher process seems to exist … but BetterTouchTool is not detecting this process …

But here is some more background on this … I’ve tried the installation many times (maybe 10 times or more with a couple of restarts of my iMac) during the day - every time checking it for the BetterTouchToolPrioWatcher process and nothing happened…

Greetings from a German user to a German Developer


Weird. Because the priority helper app runs with elevated privileges it contains more security features than usual. It e.g. validates the signatures of BTT before it changes the priority.

Possibly try downloading a fresh copy of BetterTouchTool, maybe that code signature has somehow been corrupted

Will try installing a fresh copy on my iMac when I’m back home later the day and report if this will fix the issue…

Thank you :pray:


Hello Andreas

I’ve tried it downloading a fresh copy and installing from scratch without any old data first and was asked to update the Helper Tool:

I’ve then used the quick method to update before the first visit of BetterTouchTool‘s preferences/settings and it seems to be the same as described earlier …

Nothing has changed …

I just reactivated my Lifetime License and imported my Presets.

Hopefully you can get this issue fixed in the next release.

Greetings to you and thank you for doing such a great job for us


Just ignore the issue, I'll probably remove the process priority helper tool altoghether in the near future because it doesn't have a measurable effect on modern macOS installations anymore.

Okay for my iMac this will maybe make no difference… but for my older machines which are from 2009 to 2012/13 that would be an issue … as Long as machines this old are supported by BTT it is maybe better to keep the Helper Tool.

Another thing … I’ve encountered lagging in all my gestures for my Magic Mice and Trackpads - just because of this issue … it doesn’t seem to uninstall the helper tool either.

Any ideas ?!


On the older machines this probably still works fine if they run older macOS versions as well (as the helper hasn't changed in many years :-)).

Your lagging issue is probably not related to this, but if you want to try you can run this terminal command (that's all the helper tool does):

sudo renice -2 XXX

You'd need to replace XXX with the PID of BetterTouchTool which you can find in Activity Monitor:

You can also try to disable the code signature validation using this terminal command (requires a restart of the helper tool):

sudo touch "/Library/Application Support/BetterTouchTool/.disableSignatureChecks"

1 Like

Thanks for the commands Andreas …

Since I’m developing something for myself that stores every single manipulation compared to the defaults of the system and every single app that comes with such commands and specific settings - because I always forget what I’ve set and what I need to do to reset the defaults - these commands are very helpful and will be added to my tool.

Speaking of this command - reenabling the Code Signature Validation is just enableSignatureChecks - right ?!

Thanks again


no, to enable it again you’d need to delete that file :slight_smile:

sudo rm "/Library/Application Support/BetterTouchTool/.disableSignatureChecks"

1 Like

Thank you :pray:

Appreciate your help a lot.

Greetings to you