Issues with Adobe InDesign

Back in 2021, I mentioned a bug where you can not use InDesign properly while BTT is running. So I had to disable it for InDesign.
The issue was that when BTT is active, and I double click on any page icon, to jump to the page, it seems that InDesign thinks I'm trying to move the page but let go, so I get the nope sound. :sweat_smile: I don't know how to describe this sound.

I thought that in the meanwhile, the issue would be solved by now, but it still remains.
Does anyone have the same issue, or am I the only one?

Just to make sure I understand it correctly. You double-click on a page in the side panel (screenshot) and InDesign doesn't jump to the page? I just tested it with InDesign 2020 and 2023/Ventura and it works without any problems. I've been using BTT since 2016 and InDesign every day and have never had this problem.

Bildschirmfoto von InDesign (23-02-23, 09-02-36)

No, it is a bit hard to explain. It jumps to the page, but InDesign thinks I'm trying to move a page, so the cursor grabs the page icon and tries to move it, but it lets go of the page immediately, and I get this warning sound.

Here I recorded my screen so you can better understand what I actually mean.

I can't reproduce that. The hand is not visible on my end and BTT is working. I would suggest checking the actions you've set up for InDesign. Maybe you accidentally set something up that's interfering with it.

That is weird. Do you use a mouse or the trackpad of a MacBook?
Because I'm using the trackpad. Maybe it has something to do with that? :man_shrugging:
I set up a bunch of different things in BTT, but I don't know what it could cause that.

I use the Logitech G604 mouse and have assigned the buttons via BTT. But I just tried it with the trackpad of my MacBook Pro, 16", 2021, Apple M1 Pro chip, macOS Ventura 13.2.1 and didn't have the same problem.

hm…I'm on a MacBook Pro 16" 2019, 8-Core Intel Core i9 chip, macOS Ventura 13.2.1, and the only command I have for InDesign in BTT is this one. But even when I deactivate it, the issue is still there.
I have no idea what causes the issue. Maybe @Andreas_Hegenberg has an idea. :man_shrugging:
otherwise, I can never use BTT with InDesign.
Anyways, thanks for your help.

Hi, I've had issues with InDesign and Illustrator for the past 7 or 8 years, across 4 Macbooks and different Chip architectures.
Whenever BTT is open in either program whenever you click what actually happens is a click event, then the mouse is moved a tiny bit, then the release event happens.
This makes both apps effectively unusable while BTT is open.
When I first encountered this problem it took me weeks to troubleshoot. Safe Boot would eliminate the issue but it took me forever to figure out it was BTT.
I have shut down BTT for years in order to use either tool but then all works OK.

Happens regardless of the input device: Internal / External trackpad, Magic Mouse, Logitech BT Mouse.

I set up all new Macs fresh so it would not be a legacy settings issue I am guessing.

Oh, at least I'm not the only one. Luckily I have only an issue with InDesign. But it is annoying anyways. I hope it will be fixed soon. But I have very little hope because this bug is already over several years not fixed.

Well to the Developer's credit, I never reported it so I don't know they were aware.
I'm happy to help in the analysis of this issue but don't currently know how.

Actually, I mentioned it here as a bug back in 2021, but since then, nothing changed. So I'm curious if this time anything will happen.

The only thing I can think of is that InDesign might not implement the macOS Accessibility API correctly. In that case disabling BTT's window snapping for InDesign could help. Although I was told by Adobe that they have fixed this quite a while ago.

I don't think I'll be able to fix this inside of BTT.

hm…this is very strange because @SLE seems to don't have any problems with BTT and InDesign. Does it have something to do with the M1 chip? Because I'm currently on Intel.
And I had no idea you could disable the window snapping for individual apps. I think I will give it a go. How can I do that?

maybe @SLE doesn't have window snapping enabled in BTT? I don't think it's related to M1/Intel

No, I can cofirm I've had the issue on Intel and Apple Silicon, 2 devices each.

I have the function active and have never had any problems with it

Now I tried and disabled everything, but it didn't change. :man_shrugging:
I have no idea what else to try.