Is there a way to disable touch scrolling on magic mouse with BTT?

I recently got a new mac mini, and along with that I got a magic mouse. Using the magic mouse has been absolutely horrific for me. The main complaint I have is that I am experiencing constant accidental scrolling when simply trying to move the mouse cursor position. Just last night this was happening to me constantly and driving me crazy (plus I think there is some lag with bluetooth which makes everything more obnoxious)-- for example, attempting to move my mouse with intentions to click the play head position on a video player resulted in tons of accidental scrolling which in VLC, scrolling changes volume and so I was constantly accidentally turning the volume up to 200%... But aside from the video player frustration, I was constantly having accidental scrolling happen just from navigating around the finder.

So, I am hoping there is some way to disable the touch aspect of the magic mouse, and just let me move and click-drag sliders when I need to scroll... Otherwise, it's off to the garbage bin and back to using a regular wired mouse.

Yeah, I have this same issue. I just upgraded to the new M2 Studio Silicon Mac, so my previous mouse controller—MagicPrefs—no longer works. I'm happy to find BetterTouchTool, but so far it seems to be lacking the one thing I need most: to eliminate vertical scrolling with the MagicMouse. It really is unthinkable that Apple doesn't give us a way out of this feature such a huge number of people find annoying and a disruption to workflow. Hoping BTT has a solution.


I hope this gets to you. I posted just after you did yesterday and I just found something amazing as a solution. This webpage I've found has terminal commands to turn off these gestures. I'm on a new Apple M2 Studio and was afraid they might not work in the new silicon environment, especially since the article is from 2017, but I tried them and my mouse is now totally gesture free. I do a lot of precise graphics work and I can't have my mouse cursor flitting erratically about the screen. Before upgrading to the M2 silicon chip, I had an app called MagicPrefs that took care of the problem but it won't run on the M2, and BetterTouchTool just wasn't doing it.

Go to this page, copy the commands into your terminal window, restart your computer and let me know how it goes.