iOS remote - can't remove old triggers

Noticing old triggers in BTT iOS remote won't disappear now that I've created new ones to replace them, leading to duplicates.

Have attempted reinstalling the iOS app, restarting Mac/iPhone, toggling "reset allowed devices" and "enable BTT remote support" on Mac.

BetterTouchTool Version: 4.462
iOS 17.4.1 (iPhone 13 Mini)
macOS Sonoma 14.4.1 (MacBook Pro 2021)

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
A clear and concise description of what the bug is. Any bug reports that contain insults against me or my software will be deleted without warning (unfortunately this has become necessary to mention here).

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac:
  • macOS version:
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. crash logs, related issues, etc.):