Infrequent issue with trackpad no longer recognizing clicks

Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
Sometimes (not always) after using 3 finger swipe up macOS gesture to show all windows (Mission Control), trackpad stops recognizing clicks and doesn't provide haptic feedback. Switched to magic mouse and clicks still not registering. Using spotlight and keyboard commands to relaunch BTT solves the issue, so it seems like a BTT issue not a hardware or macOS issue.

May be related to issue found here: Magic Trackpad Click Not Recognised

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):

M2 macbook air + trackpad

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: M2 Macbook Air, 2022
  • macOS version: Sonoma 14.3.1
  • BetterTouchTool version: 4.403, but has been happening for months

Additional information (e.g. crash logs, related issues, etc.):