Infrared Remote not working anymore on BetterTouchTool


I have a late 2012 mac mini, which I use as a multimedia server connected to a TV mostly to watch DAZN and KODI with the white IR remote.

It used to work beautifully thanks to BetterTouchTool, which let me customize my IR remote to play, pause and skip my favorite shows.

Shortly after my machine upgraded to Catalina, the IR remote stopped working correctly. When I press the up button, it increases the volume, when I press the down button it decreases the volume (kind of hard coded with the Mac OS and doesn't follow any of the configurations on BTT.

I tried upgrading to the latest version but it doesn't make a difference. It's like BTT doesn't see the IR remote anymore.

Other applications as KODI, which uses the IR remote (through it's own helper application) continue working correctly.

Any pointers on what could be going on?

I don't mind if I have to revert to an old BTT version as I only use the IR Remote to map specific functions as keystrokes or mouse clicks.



Unfortunately I haven't had a mac with an IR receiver for many years, which is why it's not officially supported in BTT anymore and has been removed from the new UI.

That said, there haven't been any changes to the code, so I think it should still work. Also downgrading probably won't help because there have been zero changes to this part of BTT for at least 6 years.

Possibly try running this terminal command while BTT is quit:

defaults write com.hegenberg.BetterTouchTool useAppleRemotePlugin YES

Possibly also check whether there are any permissions BTT is missing in System Preferences => Security & Privacy


Thanks for your prompt answer.

The command did work and BTT is working once again with the IR Remote. I mapped again the functions I had with the legacy UI and it is indeed working.

Only odd behaviour is that if I map the up or down key, it first brings the system overlay HUD and increases or decreases the volume + whatever action I mapped to it. Seems like the system still gets priority over the control.

*EDIT - this is solved. I realized that BTT was on "Dont use Exclusive Remote Mode". Changing this setting to false, thus allowing it to use exclusive mode, solves the problem.

Everything is working now. I had a hiccup where it suddenly stopped working and restarting BTT did not had any effect, but a system reboot cleared the problem. I am currently running 3.287. Any advantages in terms of stability with running a newer version?

Thanks! Very happy with BTT!

Hello :slight_smile: How can I see the IR remote option in the drop-down menu? I only get "siri remote". If I write in the terminal "defaults write com.hegenberg.BetterTouchTool useAppleRemotePlugin YES" is it activated or do you have to do any more steps? Thank you!