Inconsistent issues w/ insert/paste formatted rich text (Stream Deck and Touch Bar)

Computer system & versions:

  • BetterTouchTool 4.073 = currently the newest version available
  • Macbook Pro, 15” 2017 Touch Bar – Ventura 13.4 (latest OS available as of today)

SUMMARY OF ISSUE: When using “Insert / Type / Paste Custom Text” action, formatted rich text using StreamDeck and/or Touch Bar, when in Apple Pages = doesn’t work properly

WHAT: I want to have specific looking/formatted text entered when I hit the assigned button when using Apple’s Pages app. See screenshot that shows exactly what I mean or these examples between quotes, but imagine it's formatted (as I can't do so here??) : “*** BLACK BOLD” “BLUE BOLD .” or “*** BOLD WORDS BLACK *** RED BOLD *** .”)
ONLY BLUE IS IN BOLD with unbolded black period at the end .
*** 2 COLORS IN BOLD *** RED HERE *** with unbolded black period at the end .

WHY: I’m typing in Pages and I want to hit a button and have the formatted text appear (to save time having to manually format words), then I can continue on typing as normal -- this is why I include a NOT bolded period at the end, so that I can type normally in Pages without it getting 'stuck' in the formatted style setting in BTT. (That makes sense, yes?) Some of the text I want in bold, some I do NOT want it to be bold. Some in black, some in a specific color.
If it matters to know: I use a few colors (blue, red, green) – I have used the eyedropper to select the same color font that I use in Pages – so I know that Pages does have that color).

HOW: (Let's focus on Stream Deck since Apple sadly has stopped supplying laptops with Touch Bar and I have to get used to one day no longer having this option...-sad face-...) -- So: I add “Stream Deck Button” and then under “Assign First Action to Selected Trigger” I choose “Insert / Type / Paste Custom Text” – then under “Action Configuration” panel I have tried either manually typing and adjusting text as well to what format I want it to end up as, as well as just copying and pasting the formatted text from Pages to the window box in BTT – I then choose and check off “Rich Text as formatted above” under the dropdown menu option of “Paste Format”. Save. Done.
(I have multiple ones that I’ve made – I either manually create each from the start, OR I’ve copied the first column/panel one (so one that’s made) and then adjust it to be a ‘new’ one.)

ISSUES - MORE DETAIL: Inconsistent results! Mostly, it does not work as I expect it to.
I have multiples ones/buttons made. Some sometimes work fine (as wanted), some sometimes half work (see below examples), but the majority of the time they do not work at all (meaning all the rich formatting is removed/doesn’t work as intended).

  • it’s a little all over the place – it’s rather inconsistent with what it does/doesn’t do and I can’t figure out what the issue is... it's like it forgets what it's suppose to always do??
  • examples: one that used to work (contains color text that is bold and black text that is NOT), doesn’t work now (it no longer has color, only black) and/or either part is in bold (good) or all of it is no longer bolded (not good – it should be both)
  • sometimes it’ll have the two colors (ex: red and black) but it won’t be bold.
  • rarely, if ever, does it work as specified…which makes using BTT and Stream Deck (or Touch Bar) a bit difficult as I have to manually fix things in Pages as it isn’t 100% of the time working.
  • the ones that seem to work fine are the ones that are just black font and bold… which leads me to believe it struggles when you start mixing colored fonts and stylized (bold and not bold) …but it should work though, shouldn’t it?? It’s rather maddening that it might work briefly/here and there but most of the time it does not work properly.
  • sometimes for those that just seem to stop working (ie: no color, not bolded - just black unbolded/unformatted appears) if I go into BTT and just copy/paste the same thing of what I want again and 'resave' it, it'll either not work at all (zero change to the issue) or it does that half working thing again for a bit then stops...which is, weird, right?

ARE THERE OTHER OPTIONS: Please let me know what I can do to fix this issue/make it work properly all the time. I also am slightly aware that there’s some sort of Script/HTML option….? I really would need extremely beginner step-by-step instructions, a full copy/paste this exactly… I saw a post, tried to do so and nothing happens so… over my head/doing something wrong on my end, I guess?

Have you ever tried using "Insert Text by Typing" instead of "Insert Text by Pasting"? In my opinion, some apps have issues with the latter. For example, I experienced similar symptoms to the ones you described in Opera, and since I started using "Typing," they have disappeared. It takes a second to fill for longer texts, but consistent execution is more important to me in that regard.

@SLE the option to change "Insert Text by Pasting" to "Insert Text by Texting" is greyed out, it's not clickable if the text in the box I've added and customized has any formatting to it (ie my earlier examples). So, I guess that's not an option ?