I'm trying out BTT and Magic Mouse Scroll has stopped working

Hey, I'm trying out BTT (in order to disable horizontal scrolling in VSCode) and just a few days after that my Magic Mouse has stopped reacting to scrolling. I.e. now when I am in a window where I can scroll and I do the scrolling movement on my Magic Mouse, then nothing happens.

This applies to vertical and horizontal scrolling, plus it happens regardless whether BTT is running or not. I have tried fixing this by quitting BTT and by restarting with BTT not starting on login.

Also, I have tried it with two different Magic mice - and I see the same behavior. On the other hand, a Logitech bluetooth mouse with a physical scroll wheel (and no special driver installed) works perfectly (well as perfect as a non-Magic Mouse can work :wink:).

Can this issue be triggered by BTT? And if so how can I fix it?

My environment:

  • iMac 2012
  • macOS 10.15.7
  • BTT 4.073

I'm having a somewhat similar issue, I can't scroll with my Magic Mouse whilst BTT is open, and can scroll fine if I quit BTT, not sure what's causing this - I've reset all settings and don't have any mouse related triggers set up @Andreas_Hegenberg. :<

TIL "Disable single finger scrolling" is a thing and was enabled for some reason. All sorted, thanks.

Please note in my case the no-scroll issue persists even if I quit BTT!

I have no idea why this happens or how to fix it. :unamused:

Then your issue is not related to BTT. BTT can only affect scrolling while it is actively running.

However I don't know what else could be the reason, maybe some other mouse / keyboard related app you have installed?