Hyper Key not working as expected

Describe the bug
I have been using Karabiner to map the Hyper Key to Caps Lock before.
When BTT started supporting Caps Lock as Hyper Key, I uninstalled Karabiner and in BTT set up a keyboard shortcut under "All Apps" / "Caps Lock -> Act as Hyper Key".
I did leave all the other settings at their defaults ("Works on all Keyboards", "Trigger on Key Down").

I'm using a 2017 MBP 15" with Touch Bar and most times an external Magic Keyboard.
All the previously set up Hyper Key shortcuts (from the Karabiner "era") still work for the external keyboard.
But when I use the builtin keyboard, none of them work.

When trying to create a new keyboard shortcut, e.g. Hyper+F:

  • using the builtin keyboard, the recorded key is only "F" (no modifiers)
  • using the external keyboard, the recorded key is only "Caps Lock"

What am I missing?

Device information:

  • 15" MBP Touch Bar 2017
  • macOS version: 11.1
  • BetterTouchTool version: 3.541 (1680)


for recording the shortcuts in BTT you need to press all the modifier keys, the hyper key only works for triggering these shortcuts. (otherwise BTT couldn’t record the Caps Lock key itself)

Make sure that caps lock is enabled for all the keyboards in System Preferences-> Keyboard-> Modifiers (BTT‘s Hyper Key only works if Caps Lock hasn’t been remapped to something else). It sounds like for your built in keyboard it might be mapped to something else.

Thanks a lot for your quick reply!
You were spot-on with both - pressing all the modifiers when assigning a new shortcut worked as expected and I had indeed set the internal Caps Lock key to "None".
I had totally forgotten about that one, sorry about that.

Thanks for your help! :smiley:


I don't suppose there's a way to prevent the brief flash of the Caps Lock light?

nope, not as far as I know (that's because BTT can not really block the caps lock event, just disable it immediately again)

1 Like

Got it, and am I also correct that it only works with BTT shortcuts? E.g., I can't make a key combo in Moom that uses the hyperkey combination?

It works in most other apps, but it depends on the level at which the other app listens to shortcuts. Have you tried it with moom?

For incompatible apps you might try to catch the shortcut in BTT and then forward it using BTT‘s shortcut sending functionality

No luck unfortunately. Not exactly sure why but will keep trying.