Hyper Key Functionality Broken (Revisited)

I don't know whether I have configured it wrong but I find the Hyperkey functionality to be very fickle. I take the subject of my post from another earlier post that seems to describe the same issue. The Hyperkey functionality is for me one of the most useful features of BTT. When it works, it works wonderfully but then all of a sudden it doesn't work and you don't know exactly why.

In the previous cases I managed to fix it by restarting the computer or deleting the trigger and creating it again. I decided to post this, however, because it looks to me that this should not be like this. All I can say is that this time it stopped working after I rebooted my computer. It had been working without any issues for weeks.

Here's the info that might be relevant. If you can think of some other info I can provide to troubleshoot this, let me know.

Device information:

  • Type of Mac: Mac Studio
  • macOS version: Ventura 13.4
  • BetterTouchTool version: 4.073

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

Maybe some app on your machine has activated secure input mode and forgot to deactivate it. BTT would show a message about this when clicking the BTT menubar icon

Thanks for the rapid response. No, I don't get any message like this.

I don't know if I'm experiencing a similar issue or a different one. Sometimes my hyper key stops working. When I click the BTT Menubar item though suddenly comes back to life and all the key presses I'd tried are sent at once. I'm not sure if it's just the hyper key though - I believe it's all BTT actions (like those from my Stream Deck) get stuck in a queue

I still have not managed to solve the problem with the Caps Lock working as a Hyperkey. I have deleted the configuration and done it all over again. When I click on the Caps Lock, it just stays blue (indication on my keyboard that it is activated) until I press again.

The strange thing, again, is that I had it working for a while; with the same computer and keyboard. Is there anything in the System Settings that I would need to reconfigure? I have checked and BTT has accessibility, input monitoring and full disk access permissions. What else would I need for this to work?

I know it is not properly configured because when I try to set a trigger in Keyboard Maestro using the Hyperkey, KeyBoard Maestro does not recognize the pressing of the Caps Lock key as a combination of keys.

Fortunately, BTT Hyperkey works flawlessly for me :smiley:

If that wasn't the case, I would do it that way. First disable Hyperkey.

Thanks a lot for your help Frank1. Fortunately that works (i.e. I have no problem assigning the Caps Lock key to the right-ctrl key). Unfortunately I need the Caps Lock key to do what it usually does. The beauty of BTT was that I was able to do both things. If I only clicked Caps Lock, I could write in all caps. If I clicked it in combination with another key, then I had it work as the Hyperkey. I had used the Caps Lock key as a Hyperkey before using Karabiner but it had the same problem as your solution: it disabled the Caps Lock function.

I see, you want to keep the Caps Lock feature with the same key.

I don't know if this helps, but you could set it like this. When right control (Caps Lock) is double tapped (alone), Caps lock is enabled/disabled.

Yes, that could work. How would one go about doing that?

Just record a Key Sequence (on release) and give it the action toggle Caps Lock. Probably a single tap is enough. If you use Caps Lock + letter for a shortcut, the sequence will be interrupted and Caps Lock should not be activated ... I think :slightly_smiling_face:

Thanks! That worked! Now I hope I remember the setup if I haven't been using all this for a while :slight_smile: