How to execute terminal command to switch workspaces with AeroSpace?

Hello, I recently started using a window tiling manager called aerospace. It's been fantastic. In the docs, it mentions that one can leverage BTT to use trackpad gestures to switch workspaces.

Alas, I've not been able to get it to work and there appears to not be an AeroSpace forum for me to ask this question. In BTT, I've configured four-finger right and four-finger left swipe gestures, selected Execute Terminal Command (I've tried Async and non-Async) and entered the following per the docs...

aerospace workspace "$(aerospace list-workspaces --monitor mouse --visible)" && aerospace workspace next

Also, after reading some posts in this forum and attempting to use absolute paths, I'm still not coming up with the right command as nothing happens when I four finger swipe on my magic trackpad.

Would anyone have a recommendation for me? Thank you.

you need to figure out where aerospace is installed (run "which aerospace" on your normal terminal), then use the full path to it when calling it from BTT.


/usr/bin/aerospace workspace "$(/usr/bin/aerospace list-workspaces --monitor mouse --visible)" && /usr/bin/aerospace workspace next

Thank you! /opt/homebrew/bin/aerospace was my path to aerospace. It works now. I appreciate it.