How do I only make the touch bar appear with a gesture?

I'm confused and could use some help. Whenever I switch apps the BTT touch bar keeps popping up and it's driving me insane. I've tried changing every touch bar related setting in BTT to no avail. I've tried the hide touch bar, toggle touch bar and even grouped actions. The BTT toggle in the control strip also doesn't work. After a few minutes they appear again.

I just want the touch bar buttons to only appear when I want because I use the touch actions that apps have. Is there any way to do this?

Selecting "All Apps" and changing the Touch Bar mode should help:

Ohhh, thanks!

Is there any way to hide the control strip with this method? It's still there when I hide it in the settings