Hotkey window snapping on Safari Technology Preview no longer working

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS from the "User Diagnostic Reports" section.

Describe the bug
With the latest release of Safari Technology Preview in prep for Monterrey, my hotkeys assigned for window snapping (cmd+up, cmd+down, cmd+left, cmd+right, cmd+1, cmd+2, cmd+3, cmd+4) are no longer working for the application. Every other application is working as expected with the hotkeys and dragging the Safari Technology Preview window to the sides and corners to snap works as expected.

Safari Technology Preview version: Release 126 (Safari 14.2, WebKit 16612.

Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Keyboard hotkeys

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: MacBook Pro (16-inch, 2019)
  • macOS version: 11.4 (20F71)
  • BetterTouchTool version: (please post the exact version - not just "the latest one") 3.562 (1702)

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):