High Sierra security update killed my BTT

I'm hoping this is a bug rather than an orchestrated way to extract more money from me on top of my modest standard subscription from two years ago…

All I did was install the latest High Sierra security update and after the reboot, BTT had disappeared from my menubar and refused to launch - telling me it was no longer supported and I would have to buy the latest version.

My OS version hasn't changed - it's still 10.13.6 - so there is no logical reason why BTT should suddenly be incompatible. In fact, it works fine on another Mac also running 10.13.6. So what just happened?

I followed the update links and tried to choose the "downgrade to latest supported version" option but nothing happened. So how do I continue to use BTT v2.428 in Os 10.13.6 where it was working happily until yesterday?

Have you already tried to restart that machine?

if that doesn’t help I’d try to reapply the old license file again. Maybe it got corrupted during the update

Thanks for your rapid response Andreas. The problem occurred after a restart and I have restarted again for good measure - to no avail.

As soon as I try to open the BTT app I get ambushed into a "no longer supported"/"give me money to upgrade" scenario so I can't access its menus to export the licence. How can I reimport the licence when I can't get to the menus?

Double clicking the license file should work in that case.

Are you sure you are still on version v2.428 ? (otherwise maybe try to redownload via https://bettertouchtool.net/releases/btt_2.428_recovery_mojave.zip )

Thanks, I'll try that. Where does it live? I can't see it in Home>Library>ApplicationSupport>BTT…or Preferences

The license file is stored in ~/Library/Application Support/BetterTouchTool and has the file ending *.bttlicense

You can also use this free license file for such legacy versions of BTT https://boastr.net/free_legacy_license.bettertouchtool (right-click save / download)

Thanks - I'll give it a go later.

Imprint | Privacy Policy