Having trouble getting BetterTouchTool to work

Apologies if this is the wrong way to go about this, but...

I am trying to get BetterTouchTool to work for the last hour and it is not working.

I am a long-time user. I believe I had (past tense) version 2.4.xxx I just upgraded my Mac from High Sierra to Catalina and am running on MaxOS 10.15.4.
After the OS upgrade, my BTT software kept looping and trying to restart. I eventually deleted it. Then, I downloaded the latest BTT. It did not seem to run. I could get it into the Applications directory, but every time I would run it, nothing would happen.
I assumed it was because I was on a free license before and because I upgraded, it would not work. So, I bought a license. I got my activation emails. When I run the activation, it says that BTT is now Licensed. When I press OK, it says "Could not restart". Then it brings me to this BTTRelaunch program, which also seems not to do anything.
I have also rebooted my machine a number of times and nothing seems to work.
Please help. Thanks.

Try to reset the system permissions using this terminal command:

tccutil reset All com.hegenberg.BetterTouchTool

Imprint | Privacy Policy