Have to click multiple times for system to recognize a single click while BTT is open

Note: Before bug reporting, please make sure you have tried the latest (alpha) version of BetterTouchTool and that you have already tried to restart your system :-). If you encounter a crash, please attach a crash log from the macOS Console.app from the "User Diagnostic Reports" section.

Describe the bug
I have to click multiple times for the system to recognize a click while BTT is open. If I close it, click behavior returns to normal
Affected input device (e.g. MacBook Trackpad, Magic Mouse/Trackpad, Touch Bar, etc.):
Macbook Pro 15", Core i9, early 2019

If applicable, add screenshots to help explain your problem. (You can just paste or drag them here)

Device information:

  • Type of Mac: see above
  • macOS version: 12.3.1
  • BetterTouchTool version: (please post the exact version - not just "the latest one")

Additional information (e.g. StackTraces, related issues, screenshots, workarounds, etc.):

I just wanted to add that I experienced the same thing on version 3.756 of BTT. I downgraded to 3.741 and everything seems back to normal now.

I'm on a MacBook Pro (16-inch, 2021) M1. And I noticed that it happened both using a Magic Trackpad, and even if I turned off the Magic Trackpad and used the built-in one, I still had the issue.