GoldenChaos-BTT Support and Feedback Thread

feature-request
bug

#1342

Great work!

Yes, same. I plan to add some kind of auto but for now, the hidden action is what it is right now. This is why I discussed the method to run this. I guess you can’t afford to run it like a normal widget because itll run forever and not only when a specific app is open....

How do you check for the ‘on import?’ I’d really like to know that!
Aand lastly checking right when settings are open is basically what I’m doing now :wink:

I’ll check out your preset soon and let you know if any issues occur.

Remember! You can view and munipulate BTT variables with this file:

~/Library/Application Support/BetterTouchTool/btt_user_variables.plist

#1343

I did not know about that plist file!!


#1344

Yep, everything works! Thank you!


#1345

Question: not sure if this has been covered already.. but with the Emoji picker - any way to make it so that it doesn't disappear after one emoji? Makes it hard to emoji spam.....

Edit: second question - say for example I turn off the command and option modifier menus. The default is to quickly shrink the menu bar. Is it possible to set it to NOT shrink the menu bar?


#1346
  • Definitely an option I can add!
  • Also definitely an option I can, uh, try to add! There are some complications here, but the short of it is really just "it would be a bit more work". But I think it would be worth it so I'm gonna try :smiley:

#1347

Thanks! Re: the second one - I went ahead and just changed all my "menu bar" icons to always show regardless of modifier keys. Doing this manually achieves what I want so not a huge issue if it's too much work!

A new inquiry here: if I were to then upgrade to the latest version of GC-TouchBar through the recommended steps i.e. remove the preset entirely, reinstall new, and click on "restore preexisting configuration" - would this revert back to all of my manual changes as well?


#1348

Ahh, the reason I want to implement it as an official setting is because it's not totally obvious how to do this correctly, in a way that doesn't break how the menu bar works inside certain widget groups.

(You did it wrong, btw - you need to keep it set to "show if NO modifiers..." and uncheck the "CMD" box for each widget. DON'T change it to "always show regardless of modifiers" or they will show up in places where you don't want them to. But I wouldn't have expected you to ever know this!)

Also, I think not shrinking the menu bar is the better default option. In truth, this was a bit of a "bug as a feature" thing, haha. I might keep it around as an additional setting, though, but I have to write a function that checks every menu bar widget for every case of modifier combinations to properly adjust those checkboxes automatically. So that's 9 combinations to start! Can't wait for that fn menu to work :smiley:

When you upgrade, I can only restore settings set through the settings window, since they're explicitly tracked by BTT when you set them. Everything else gets wiped out when you remove the preset unless you've copied it to your own preset first. For minor changes this isn't a big deal, but some people probably have whole forks that they keep for themselves with various modified widgets, and for something like that the best way to do it is to have your own preset next to GC-BTT and copy your modified widgets in.


#1349

@GoldenChaos

I have some other tips here!
Tips and Tricks for making BTT Editing Easier


#1350

That drawer trick is sweeeeeet. Will hold me over until the new UI is available haha.


#1351

Hello,

I'm using BTT + GoldenChaos

I want to use the TipTap Left & Right to switch tabs in Chrome and Safari.

I also have switched Command with Control via System Preferences.

So even by the keyboard shortcuts I can't switch tabs in both browsers...

Is there any solution for this?


#1352

Cheers - thanks for that tip. I was wondering why my CTRL modifier key was looking a bit strange.

One more suggestion: when in mission control /launchpad/expose, the native "ESC" function would exit out of that when open. In GC-BTT this functionality no longer works. Is there a way to re-enable this (while keeping in-tact the long-press fullscreen function)?

Thanks for all of your hard work.. been a BTT user for 3+ years and have only now realized how powerful the BTT can be. Finally checked this off my to-do list heh.


#1353

Whoa, I have never noticed that esc key issue before. I feel like this is a bug in BTT's esc key implementation? My esc key isn't doing anything fancy so I can't imagine it would be anything else, and I don't see any settings that might address this.

@Andreas_Hegenberg - confirm esc implementation bug or offer workaround?


#1354

That's a system limitation. macOS disables all custom Touch Bars while in Mission Control or "Show Desktop"


#1355

Good to know. Will include this in my (eventual) FAQ :smiley:


#1356

Hi there, I've got an interesting issue wherein my calendar home strip widget doesn't work. I have icalbuddy installed and know that it works because I can long-press the time and it'll give me the calendar modal widget with all my events, but the standard little home strip widget isn't working for me. Any ideas what this could be?


#1357

Bump....any help is appreciated...


#1358

Apologies, I thought I responded for some reason!

Anyways, my suggestion is to actually change the modifiers back to default and map the tiptaps to the keyboard shortcut. That's probably not what you wanted to hear, but I'm not sure of another way to do it. (I've also never swapped my modifier keys before, so I don't know what other issues this can cause.) If that's not an option for you, I'm unsure why specifically they wouldn't work with remapped modifier keys, but I can imagine why it would cause problems.

@thom.w Can you open the BTT preferences window, find the calendar widget under "Global" on the Touch Bar tab in the Home Strip section, double click it, then click "Run Script" and paste a screenshot of whatever it shows after that?


#1359

Where are we with the Spotify Play/Pause bug (the icon does not toggle to pause when music is playing...it always shows play even though tapping it does pause the music)

I know this was reported before, and was being worked on, but even after upgrading to the latest version (and loosing all of my presets despite following the upgrade directions that said they would be retained) and still the button is broken.

At one point a user made a graphic with both play and pause in the same icon, that works sometimes, but it would be nice if it worked as expected.

Any ideas?


#1360

I think you're talking about a very, very old version of the media controls. Those were completely scrapped and replaced even in the current stable version. So, if you're having an issue with Spotify and the play button, maybe you're not using the now playing controls from my preset?

Something about your configuration in general sounds strange, and it doesn't sound like you followed the upgrade instructions properly. But it also sounds like a lot of other stuff is potentially wrong, too.

Can I see a screenshot of your Touch Bar?


#1361

Hi again - just a general question: wondering what the expected battery impact of running BTT TouchBar may be, and in particular, the GC-BTT setup? Might be a better question overall for @Andreas_Hegenberg but thought others might be interested. Apologies if covered before.