GoldenChaos-BTT development updates + roadmap

Doing final upgrade testing now - I'm gonna post up the new version without screenshots for the sake of getting it out ASAP. As long as nothing goes completely wrong during this upgrade test the release will be imminent :smiley:

@PeterV My 12-hour Power for BTT is 7.10, so 5-8 sounds correct to me. This is the nature of the beast because GC-BTT isn't a native app, so it's doing a lot of inefficient things via AppleScript to make itself work. The only way around it would be to fully rewrite it as a native standalone app, but that's a bit beyond my current app development skill level. Maybe one day... :sweat_smile:

EDIT: Found one small oversight in the upgrade process for existing users; with the new preset system, I need to make sure it checks whether or not you had GC already installed so it doesn't activate the "Default" preset. That's the only issue I found, though, so I'm gonna fix that and push this out!!

1 Like

The new update is out, go get it!! :grinning_face_with_smiling_eyes:

Release notes:

Thank you very much :+1:

there is a helper apps,name is stats,but its not useable now。

thank you very much !!!!

"preference -> menu bar -> show battery Percentage" (not work) for next update !!!

edit : change option "preference -> menu bar -> battery" from dynamic to always , and again dynamic.
after that the option "show battery Petcentage" work !!!!

Thanks for the Update, for perfectly for me , no problem after 3 hours of use :crazy_face:
preference -> menu bar -> show battery Percentage -> works for me

1 Like

The new GC version works great. I look forward to your documentation about the preset in the GC-BTT settings UI.

I tried changing the preset myself, and found that I cannot go back to my original custom setting once I select a "standard" or "community" preset. This is not an ideal behavior, can you offer a mechanism to persistently save our own customer setting? I tried reimporting the GoldenChaos presets that I exported as backups (with or without settings), but somehow my GC settings (such as menu bar selections and disabled triggers) were not restored.

I ended up using Time Machine to restore the entire Application Support/BetterTouchTool folder to get back my own GC settings.

This is super valuable feedback. There are definitely a few quirks I need to work out. What you're describing is definitely a bug because it's already supposed to be persistently saving your custom settings.

I think I know what's causing the bug; I think it's not saving custom settings on upgrade properly. So although it correctly says "Custom Settings" when you upgrade GC to the latest version, I think it's failing to actually set your custom settings for the first time in the background, which would then cause them to be "overwritten" if you switched presets.

Unfortunately, you'll have to set your GC settings again - I'm really sorry about that. But I'm working on a fix for this right now since it's super critical this doesn't happen to other people. Thank you for reporting this!!

I've also been able to confirm the Battery Percentage toggle broke somehow. I'll have a new version out today with fixes for both of these things :grinning_face_with_smiling_eyes:

1 Like

Thanks for confirming the bug on saving preset settings. For those affected, if you have a Time Machine backup, you can restore everything using an earlier version of ~/Library/Application Support/BetterTouchTool. It worked for me.

1 Like

While you are fixing the bugs, please note that the GoldenChaos menubar item "Toggle System Touch Bar UI" does nothing. (I remember it worked in 3.392, but I cannot say for sure because I manually disabled the menubar icon.)

That was definitely working before, weird. Will get that fixed that as well!

By the way - once you set your custom settings again, they should persist. Let me know if that's not working as expected! I'm pretty much going through the entire preset system and doing a thorough testing of various edge cases and upgrade paths :slight_smile: Gotta make sure this is rock-solid if I want to eventually introduce more presets and workflow modes!

Finally: it's on my list to allow you to be able to save multiple custom presets, rename them, and even eventually export/import them, but that was just way too much for the first implementation, haha. But I wanted to mention that it'll definitely happen!

No, I simply cannot go back to choose "custom settings" again once I click on any other setting. (I will have to use my time machine again. :slight_smile:)

Hey, thanks for the update! I had been following this thread in the hopes that it would fix a bug that I have notices since I upgraded to Big Sur. The bug is still, unfortunately.
The "Do not disturb" toggle seems to only successfully toggle sometimes. It doesn't do anything most of the times it's pressed for me.
It also doesn't seem to be picking up the current DND state to change the icon color in the touchbar. It no longer turns purple when DND is active.

I'm actually not encountering this bug. Is it maybe an M1 Mac issue? This feature is totally working for me on my Intel machine on the latest Big Sur, so any info you can provide about your config can help me reproduce this :slight_smile:

Sure, I can provide some more context on my setup.
I'm actually on an intel based 16-inch macbook pro (2019). I just upgraded to big sur last week, and I started seeing this issue after the upgrade.
I use the DND button often now that I'm working from home and need to prevent popups when I'm sharing my screen during meetings, so I noticed the issue pretty quickly after the OS upgrade.

Hey again! I wanted to give you an update. It turns out that it the issue was that Notification Center keeps not responding, so killing it and restarting allows things to work correctly again. So this was actually a Big Sur issue. The touchbar button is correctly toggling the DND state, but the icon color in the touchbar does not update every time, but I can live with that.

1 Like

It's one of my favorite things when GC is so reliable that it even uncovers problems with macOS :grinning_face_with_smiling_eyes:

Speaking of uncovering problems, I just wanted to let you guys know I'm still working on the bug fix update - I'll post here as soon as I'm done testing and readying the release!

One more data point on the GC 3.562 preset bug: I now know that I should just keep the "custom setting" on the Preset page and not click any other button. However, there is a bug even in this state.

I was trying to add a menu bar icon "Volume Mute" today by sliding the relevant button on the Menu Bar UI page. After I selected this icon, I found that I could no longer deselect it. More precisely, the UI showed that "Volume Mute" was deselected, but this button persisted on the Touch Bar. Restarting BTT did not help. I again had to use Time Machine to restore to the previous state.

In GC 3.392, I was able to easily select and deselect any menu bar icon.

I'm able to reproduce this issue. It crashes BTT entirely, weird. Luckily it seems to be just the volume mute button. Will be fixed in this bug fix update, thanks for the report :slight_smile:

Imprint | Privacy Policy