French accents with keyboard shortcuts


Using an English QWERTY keyboard, I would like to type French accents characters by holding down their 'main' key, i.e. holding:

  • "e" would input "é"
  • "a" would input "à"

Any idea how I could do this. I tried to explore keyboard shortcuts but couldn't add those special characters as actions nor could I use double normal keys.

You want to type "e" and get "é"? If so, just set up it exactly like that as a shortcut. But then you lose the "e". To prevent this, you can use short/long press.

Yes that's exactly what I want and also wanted to use hold down but can't find where to add the 'é' in the list of actions. Can you help?

Sure, but I have to use another example because of my keyboard. Let's say you want to type "e" and get "a". Set that up.

Yes it works on my French keyboard but when I switch to English, it doesn't as English layout doesn't have that character by default.
Not sure if there is a workaround.

Ok, then try the "type" action

Oh I think this could work! Thanks

Now I can't use the letter "e" anymore haha although I specified holding time for the action to happen.

Any idea?

You must set up both actions, long and short press.

I tried different ways but can't seem to make this work properly.

If you have time today or tomorrow can you please send screenshots of how you would set up both short and hold actions (can use any random text/character for the example).


Good morning, I'm afraid I have to leave. You can find an example with screenshots here. Try which minimum/maximum settings work best for you.

Yeah that's what I did but doesn't work. Also makes BTT crash when having those 2 actions enabled.

Ah, what you do not see in this example ... If you set up e = e you have to click "prevent recursive triggers".

Tried this as well but now when I type, got this this weird bug where the key I press after "e" shows before "e".

For ex, I will press "e" then spacebar, space will be first so " e" instead of "e " unless I wait a tad longer than my natural typing speed if that makes sense. It happens no matter what maximum hold time I set up.

Yes.... I didn't know you are a fast writer. Welcome to the club :smile: :frowning_face: for us this long/short thing does not work satisfactorily. The problem is that one action is triggered when the key is released. But the following key is triggered when pressed. So…

Hmm ok makes sense! I guess no solution as of today then.

There are many other possibilities. Which letter do you need more often e or é?


with 'e' I would need "é", "è", "ê"
then got "a" and "à"
"c" and "ç"
"u" and "ù"

Ok... what about the macos "bubble"?

Yeah might resolve to do this or remap a couple of keys I never use on english keyboard and retrain my muscle memory.

Could also just switch to French keyboard as an input source when typing in French as I pretty much never look at the keyboard while typing.

Will experiment and see what fits best.

Thanks for your help anyway!